Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.9.4

Bug #13939 pecl install fails when /tmp mounted with noexec,noatime
Submitted: 2008-05-19 07:00 UTC Modified: 2008-05-24 03:05 UTC
From: docunext Assigned:
Status: Bogus Package: PEAR (version 1.7.2)
PHP Version: 5.2.5 OS: Debian GNU/Linux
Roadmaps: 1.8.0alpha1    
Subscription  


 [2008-05-19 07:00 UTC] docunext (Albert Lash)
Description: ------------ I had /tmp mounted with noexec,noatime and autoconf failed. Once I remounted with defaults it worked. Test script: --------------- apt-get install php5-dev libsvn-dev pecl install channel://pecl.php.net/svn-0.3 Expected result: ---------------- Successful install Actual result: -------------- downloading svn-0.3.tgz ... Starting to download svn-0.3.tgz (20,724 bytes) ........done: 20,724 bytes 4 source files, building running: phpize Configuring for: PHP Api Version: 20041225 Zend Module Api No: 20060613 Zend Extension Api No: 220060519 /usr/bin/phpize: /tmp/pear/temp/svn/build/shtool: /bin/sh: bad interpreter: Permission denied Cannot find autoconf. Please check your autoconf installation and the $PHP_AUTOCONF environment variable is set correctly and then rerun this script. ERROR: `phpize' failed

Comments

 [2008-05-24 03:05 UTC] doconnor (Daniel O'Connor)
If you've said "you aren't allowed to execute scripts in this directory", and there's an error saying "/bin/sh: bad interpreter: Permission denied"... I can't see how this is a bug - a pain to have to mess around with, buy not a bug...
 [2008-07-09 13:42 UTC] demetri (Demetri Karavas)
Definitely not a bug. If you Google this you'll see that this is a problem for many people. Yes it's a pain but on a system where `pear install x` works but `pecl install x` doesn't it leads me to think that perhaps something does need to be updated. It seems mounting /tmp with noexec is a pretty standard thing hosting companies do for security that not having the installer use another directory looks like an oversight.