Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 2.0.4

Bug #13933 Translation2_Container_dataobjectsimple::getOne() - undefined variable $string
Submitted: 2008-05-18 11:03 UTC Modified: 2008-05-18 12:56 UTC
From: florent Assigned: quipo
Status: Closed Package: Translation2 (version 2.0.0)
PHP Version: 5.2.6 OS: OSX and Linux
Roadmaps: (Not assigned)    
Subscription  


 [2008-05-18 11:03 UTC] florent (Florent Bourgeois)
Description: ------------ Unable to use the get() method. The getOne() method from the DataObject Container use an undefined variable : $do->translation = $string instead of $stringID Test script: --------------- My translation data : (1, NULL, NULL, 'en', NULL), (2, NULL, NULL, 'fr', NULL), (3, 3, NULL, '-', 'smallTest'), (4, 3, 'testGroup', 'en', 'example'), (5, 3, 'testGroup', 'fr', 'exemple'); echo $tr->get('smallTest', 'testGroup', 'fr'); Expected result: ---------------- Should echo "exemple". Actual result: -------------- Undefined variable: string file : /usr/local/php5/lib/php/Translation2/Container/dataobjectsimple.php line : 207

Comments

 [2008-05-18 11:53 UTC] doconnor (Daniel O'Connor)
Hi Florent, are you able to expand out your test case a bit? For those of us who aren't familiar with the package, there's not quite enough for us to easily reproduce the problem at the moment...
 [2008-05-18 11:56 UTC] doconnor (Daniel O'Connor)
Actually, nevermind - the problem is obvious when you look at it.
 [2008-05-18 12:02 UTC] quipo (Lorenzo Alberton)
@Daniel: I'm already building a testcase, should be done soon.
 [2008-05-18 12:56 UTC] quipo (Lorenzo Alberton)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.