Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.2.0

Bug #13907 output format is always xml
Submitted: 2008-05-15 14:02 UTC Modified: 2008-05-16 18:12 UTC
From: farell Assigned: kguest
Status: Closed Package: PEAR_Size (version 0.1.2)
PHP Version: 5.2.5 OS: windows xp
Roadmaps: 0.1.3    
Subscription  


 [2008-05-15 14:02 UTC] farell (Laurent Laville)
Description: ------------ It's a bit late, but I've not yet tested the new alpha version 0.1.2 since I've upgrade it from 0.1.1 on April 8. Here are what I found, and was surprised by results : pearsize -C -h php_compatinfo -C with or without -h gave the same result (no human display, if CSV format asked) pearsize -s php_compatinfo gave me XML output without giving -X switch The worst is when you combine -s with -X pearsize -s -X php_compatinfo gave a Fatal Error Same problems found with PEAR command integration pear size ..... And last , file type filter -t switch does not work anymore as 0.1.1 (split result on text result) while it seems to be on XML results And have a look on XML result (first line begin with "channel,package,total,php,doc") A compilation of problem on the same bug reference Actual result: -------------- Fatal error: Cannot redeclare class PEAR_Size_Output_XML in PEAR\Size\Output_xml.php on line 68 pearsize --type=php,doc php_compatinfo Total: 1137303 pear.php.net: ============= Total: 1137303 +--------------------------------------------+----------+ | PHP_CompatInfo | 1137303 | +--------------------------------------------+----------+ pearsize --type=php,doc -X php_compatinfo channel,package,total,php,doc <?xml version="1.0" encoding="UTF-8"?> <pear_size version="0.1.2"> <channel name="pear.php.net"> <package name="PHP_CompatInfo" total=1137303> <role name="php" total=1120323/> <role name="doc" total=16980/> </package> </channel> </pear_size>

Comments

 [2008-05-16 07:37 UTC] kguest (Ken Guest)
Thanks Laurent, The no human display option is intentionally ignored for CSV and XML output. I will look into fixing the rest tonight. k.
 [2008-05-16 18:12 UTC] kguest (Ken Guest)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. already fixed in cvs (duplicate of bug #13630 plus misc other issues that are also fixed in CVS) - will roll out a new package.