Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.1.15

Request #13601 cannot trivially find the current version
Submitted: 2008-04-05 09:55 UTC Modified: 2010-03-16 06:51 UTC
From: topbit Assigned: clbustos
Status: Closed Package: PHP_Beautifier (version 0.1.13)
PHP Version: 5.2.1 OS: irrelevant
Roadmaps: 1.0.0RC1    
Subscription  


 [2008-04-05 09:55 UTC] topbit (Top Bit)
Description: ------------ add -V & --version options to display the current version. (-v is already used for 'verbose') Test script: --------------- php -V php --version Expected result: ---------------- PHP Beautifier 1.1.13 PHP Beautifier 1.1.13 (One each for -V and --verbose) Actual result: -------------- Console_Getopt: unrecognized option -- V Console_Getopt: unrecognized option --version (both followed by the --help text)

Comments

 [2008-05-03 03:40 UTC] doconnor (Daniel O'Connor)
`pear list` doesn't cover this requirement by any chance?
 [2008-06-22 04:55 UTC] topbit (Top Bit)
it's possible to manually install a PEAR package, so 'pear list' would not be available.
 [2008-06-23 09:05 UTC] clbustos (Claudio Bustos)
In the roadmap!
 [2010-03-16 06:51 UTC] clbustos (Claudio Bustos)
-Status: Open +Status: Closed -Assigned To: +Assigned To: clbustos
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. Added --version to display the current version.