Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.1.0RC2

Bug #1350 multipart/related messages containing attachments not parsed correctly.
Submitted: 2004-05-06 00:21 UTC Modified: 2006-12-26 23:06 UTC
From: mail at andreas dot id dot au Assigned: richy
Status: Closed Package: Mail_IMAP
PHP Version: 5.0.0RC2 (Release Candidate 2) OS: FreeBSD
Roadmaps: (Not assigned)    
Subscription  


 [2004-05-06 00:21 UTC] mail at andreas dot id dot au
Description: ------------ First of all thank you for providing a great tool for me to use. I have found Mail_IMAP easy to use and follow and am making good progress using it on PHP5. Now to the problem I am having. Certain email types are not being parsed correctly by the program. It does not transfer all of the details of the message and produces the error notice "Fallback pid used for mid: ". I have attached a cut-down version of the message showing you the headers and mime parts. Reproduce code: --------------- From andreas@andreas Mon Jul 7 18:52:49 2003 -0000 From: "Andreas Koepke" <andreas@wabusinessnews.com.au> To: <mail@andreas.id.au> Subject: Date: Mon, 7 Jul 2003 18:49:34 +0800 Message-ID: <NEBBKGGHILJACEDILDPKIECJDGAA.andreas@wabusinessnews.com.au> MIME-Version: 1.0 Content-Type: multipart/mixed; boundary="----=_NextPart_000_05C6_01C3BACC.03AE86D0" X-Priority: 3 (Normal) X-MSMail-Priority: Normal X-Mailer: Microsoft Outlook IMO, Build 9.0.2416 (9.0.2911.0) Importance: Normal X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165 X-OlkEid: D5444E2080CA182C75010D4E8B7226DC4CCEA66A X-UIDL: 0p;!!CJ:"!ZW*"!hm"#! X-NortonAV-TimeoutProtection: 0 Status: RO X-Status: X-Keywords: X-UID: 2 This is a multi-part message in MIME format. ------=_NextPart_000_05C6_01C3BACC.03AE86D0 Content-Type: multipart/related; boundary="----=_NextPart_001_05C7_01C3BACC.03AE86D0" ------=_NextPart_001_05C7_01C3BACC.03AE86D0 Content-Type: multipart/alternative; boundary="----=_NextPart_002_05C8_01C3BACC.03AE86D0" ------=_NextPart_002_05C8_01C3BACC.03AE86D0 Content-Type: text/plain; charset="iso-8859-1" Content-Transfer-Encoding: 7bit >From Andreas Koepke IT Manager WA Business News ------=_NextPart_002_05C8_01C3BACC.03AE86D0 Content-Type: text/html; charset="iso-8859-1" Content-Transfer-Encoding: quoted-printable <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"> <HTML><HEAD> <META http-equiv=3DContent-Type content=3D"text/html; = charset=3Diso-8859-1"> <META content=3D"MSHTML 6.00.2800.1170" name=3DGENERATOR></HEAD> <BODY> <DIV> </DIV><FONT face=3DVerdana size=3D2><BR>From <BR><BR>Andreas = Koepke=20 <BR>IT Manager <BR>WA Business News <BR><BR>P: (08) 9227 9544 <BR>F: = (08) 9227=20 6503 <BR>E: <A=20 href=3D"mailto:andres@wabusinessnews.com.au">andreas@wabusinessnews.com.a= u</A>=20 </FONT><BR><BR><A href=3D"http://www.wabusinessnews.com.au/bol.php"><IMG = src=3D"cid:480204910@07072003-284a" border=3D0></A>=20 <DIV> </DIV></BODY></HTML> ------=_NextPart_002_05C8_01C3BACC.03AE86D0-- ------=_NextPart_001_05C7_01C3BACC.03AE86D0 Content-Type: image/gif; name="email_banner.gif" Content-Transfer-Encoding: base64 Content-ID: <480204910@07072003-284a>

Comments

 [2004-05-06 00:42 UTC] richy
Hi, thanks for the bug report. Please forward problem messages to demo at smilingsouls dot net, where I may test the message using my own debugging tools. When you forward the message, make sure that it maintains the same structure in the forwarded message as you are now seeing, e.g. don't attach it to another message. This makes things much easier for me. Regards, Richard York
 [2004-05-06 00:57 UTC] mail at andreas dot id dot au
I just forwarded you the email so you can have a look at it. I forwarded a copy to myself and confirmed that it has done the same thing so you should have no worries reproducing the error.
 [2004-05-06 05:52 UTC] richy
Thanks again for the bug report! This fix will appear in the next release of Mail_IMAP. Regards, Richard York
 [2006-02-09 11:48 UTC] deanj at cleancode dot org
Does this bug still exist because I'm having the same problem with the latest version of Mail_IMAP. I have a message that is experiencing the same issue. Here it is a stripped down version of what I'm getting: Return-Path: <john@nospam.com> Delivered-To: deanj@nospam.org Received: (qmail 13404 invoked by uid 89); 9 Feb 2006 05:57:51 -0000 Received: from fed1rmmtao06.cox.net (68.230.241.33) by snaghosting.com with SMTP; 9 Feb 2006 05:57:51 -0000 Received: from [10.0.1.2] (really [68.5.216.101]) by fed1rmmtao06.cox.net (InterMail vM.6.01.05.02 201-2131-123-102-20050715) with ESMTP id <20060209060110.SEPV20050.fed1rmmtao06.cox.net@[10.0.1.2]> for <deanj@nospam.org>; Thu, 9 Feb 2006 01:01:10 -0500 Mime-Version: 1.0 (Apple Message framework v746.2) To: Dean Spammer <deanj@nospam.org> Message-Id: <9DBCCDB4-DA97-4039-92F7-00090A72F0A0@nospam.com> Content-Type: multipart/mixed; boundary=Apple-Mail-25-96473172 From: John Spammer <john@nospam.com> Subject: Taboo Tan Date: Wed, 8 Feb 2006 22:02:26 -0800 X-Mailer: Apple Mail (2.746.2) --Apple-Mail-26-96473174 Content-Transfer-Encoding: base64 Content-Type: application/applefile; name="taboo.jpg" Content-Disposition: inline; filename=taboo.jpg AAUWBwACAAAAAAAAAAAAAAAAAAAAAAAAAAMAAAAJAAAAPgAAAAoAAAADAAAASAAAAAkAAAACAAAA UQAAvqpKUEVHOEJJTQQAdGFib28uanBnAAABAAAAvjwAAL08AAAAbgAAAAAAAAAAAAAAAAAAAAAA AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAABQT QWRvYmUgUGhvdG9zaG9wIDcuMAAAKVApUAAAAAAAaQCAABEC/wwA//4AAABIAAAASAAAAAAAAABp AIAAAAAAAKEB8gAWOEJJTQAAAAAAAABpAIBHcolwaIGBrwABAAoAAAAAAGkAgIIAAAAm6gAAAAEA AAAAAAAAAAAAAAAAAAABAAAAAAAAAAAAAAAAAABAAAAAAAAAAAAAAAAAAAAAAEAAAAAAAGkAgAAA AwAAAAAAAAAAVmpwZWcAAAAAAAAAAAABAAFhcHBsAAAAAAAAAwAAgABpAEgAAABIAAAAACZPAAEM --Apple-Mail-26-96473174--