Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.9.5

Bug #13386 "pear install --register-only" fails with cfg role
Submitted: 2008-03-13 09:08 UTC Modified: 2008-05-14 16:26 UTC
From: timj Assigned: cellog
Status: Closed Package: PEAR (version 1.7.1)
PHP Version: Irrelevant OS:
Roadmaps: 1.7.2    
Subscription  


 [2008-03-13 09:08 UTC] timj (Tim Jackson)
Description: ------------ Using --register-only throws warnings Warning: md5_file(/path/to/pkgxml-directory/cfg.ini): failed to open stream: No such file or directory in PEAR/Installer/Role/Cfg.php on line 53 ... Could not rename /var/tmp/savefile to /my/pear/cfg_dir/cfg.ini copy(/var/tmp/savefile): failed to open stream: No such file or directory ERROR: commit failed With the patch for bug #13315, the commit doesn't fail, though the warnings still exist and I don't think the config file handling is actually doing anything (that's correct though, with --register-only it shouldn't be touching the filesystem).

Comments

 [2008-05-13 00:22 UTC] cellog (Greg Beaver)
I can't reproduce this behavior - just committed a test to check for it. Please advise or provide a test script.
 [2008-05-13 23:19 UTC] cellog (Greg Beaver)
does the attached patch fix the issue?
 [2008-05-14 16:26 UTC] cellog (Greg Beaver)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. I have a feeling it will be a while before I hear from Tim, so I am going to assume this fixes the issue