Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.3.13

Bug #13361 Unable to add() some files (ex. mp3)
Submitted: 2008-03-10 05:37 UTC Modified: 2012-04-05 09:48 UTC
From: pracucci Assigned: mrook
Status: Closed Package: Archive_Tar (version 1.3.2)
PHP Version: 5.2.5 OS: Linux
Roadmaps: 1.3.10    
Subscription  


 [2008-03-10 05:37 UTC] pracucci (Marco Pracucci)
Description: ------------ I have created a tar.gz and I have added an mp3 file, using the add() method. Then, I have uncompressed the archive and I've got the following error: tar: Skipping to next header tar: Error exit delayed from previous errors I have tried with several mp3 files and I get the same error. I don't have any problem if I add other kind of files, like documents or images. Have you ever had a similar problem?

Comments

 [2009-08-18 22:26 UTC] mrook (Michiel Rook)
-Status: Open +Status: Feedback -Assigned To: +Assigned To: mrook
Thank you for taking the time to report a problem with the package. This problem may have been already fixed by a previous change that is in the CVS of the package. Please log into CVS with: cvs -d :pserver:cvsread@cvs.php.net:/repository login and check out the CVS repository of this package and upgrade cvs -d :pserver:cvsread@cvs.php.net:/repository co pear/Archive_Tar pear upgrade pear/Archive_Tar/package2.xml or pear upgrade pear/Archive_Tar/package.xml If you are able to reproduce the bug with the latest CVS, please change the status back to "Open". Again, thank you for your continued support of PEAR. Using this code: <?php require_once 'dev/Archive_Tar/trunk/Archive/Tar.php'; @unlink('test.tar.gz'); $archive = new Archive_Tar('test.tar.gz', 'gz'); $archive->add(array('test1.mp3')); ?> and a 15 mb mp3 file, I can't reproduce this using current sources of the package, can you please confirm this problem still exists?
 [2010-01-04 20:29 UTC] mrook (Michiel Rook)
-Status: Feedback +Status: Assigned -Roadmap Versions: 1.3.4, 1.3.6 +Roadmap Versions: 1.3.6
I am able to reproduce this now.
 [2010-03-09 10:25 UTC] mrook (Michiel Rook)
-Roadmap Versions: 1.3.6 +Roadmap Versions: 1.3.7
 [2010-04-25 21:30 UTC] mrook (Michiel Rook)
-Roadmap Versions: 1.3.7 +Roadmap Versions: 1.3.8
 [2012-04-05 09:20 UTC] mrook (Michiel Rook)
-Roadmap Versions: +Roadmap Versions: 1.3.10
 [2012-04-05 09:48 UTC] mrook (Michiel Rook)
-Status: Assigned +Status: Closed
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.