Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.0.0

Bug #13348 PHP warning message when not using timestamps
Submitted: 2008-03-08 18:57 UTC Modified: 2008-03-10 06:09 UTC
From: xaglen Assigned: bastianonken
Status: Closed Package: HTML_TagCloud (version 0.2.0)
PHP Version: 5.2.4 OS: Linux (Fedora)
Roadmaps: (Not assigned)    
Subscription  


 [2008-03-08 18:57 UTC] xaglen (Glen Davis)
Description: ------------ When not using timestamps in any tags, _calcMumEpoc returns a warning message, to wit: PHP Warning: min() [<a href='function.min'>function.min</a>]: Array must contain atleast one element in /usr/local/lib/php/HTML/TagCloud.php on line 602 It does the same thing in the max call on line 603. Solution: check if array is empty before calling min or max.

Comments

 [2008-03-10 06:09 UTC] bastianonken (Bastian Onken)
Thank you for your bug report. This issue has been fixed in the latest released version of the package, which you can download at http://pear.php.net/get/HTML_TagCloud