Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.9.4

Bug #13323 Deprecated errors in many places
Submitted: 2008-03-06 05:43 UTC Modified: 2008-03-24 23:59 UTC
From: hubbitus Assigned: hubbitus
Status: Closed Package: PEAR (version 1.7.1)
PHP Version: HEAD CVS-2007-12-03 OS: Linux
Roadmaps: 1.7.2    
Subscription  


 [2008-03-06 05:43 UTC] hubbitus (Pavel Alexeev)
Description: ------------ In PHP-5.3.0 from CVS 2008-02-26 (it is not in dropdown list of PHP versions) in many case using pear, get a lot of errors like: PHP Unknown error: is_a(): Deprecated. Please use the instanceof operator in /usr/share/pear/PEAR.php on line 281 AND PHP Notice: Undefined offset: 8192 in /usr/share/pear/pearcmd.php on line 424 AND PHP Unknown error: get_magic_quotes_runtime() [http://php.net/function.get-magic-quotes-runtime]: This function is deprecated and removed in PHP 6. See http://php.net/{migrate}#get_magic_quotes_runtime for details. in /usr/share/pear/PEAR/Registry.php on line 1047 PHP Unknown error: set_magic_quotes_runtime() [http://php.net/function.set-magic-quotes-runtime]: This function is deprecated and removed in PHP 6. See http://php.net/{migrate}#set_magic_quotes_runtime for details. in /usr/share/pear/PEAR/Registry.php on line 1048 AND PHP Unknown error: Assigning the return value of new by reference is deprecated in /usr/share/pear/PE AR/Frontend.php on line 90 Last message perhaps is also relevant to http://pear.php.net/bugs/bug.php?id=10196 , http://pear.php.net/bugs/bug.php?id=12616 , http://pear.php.net/bugs/bug.php?id=12071 Test script: --------------- Just run command: $pear list Expected result: ---------------- Normal list of installed pear-packages, without lots (for example I get ~174Kb of trash!) errors. Actual result: -------------- PHP Notice: Undefined offset: 8192 in /usr/share/pear/PEAR/Frontend.php on line 90 PHP Stack trace: PHP 1. {main}() /usr/share/pear/pearcmd.php.orig:0 PHP 2. error_handler() /usr/share/pear/pearcmd.php.orig:0 Notice: Undefined offset: 8192 in /usr/share/pear/PEAR/Frontend.php on line 90 Call Stack: 0.0042 489264 1. {main}() /usr/share/pear/pearcmd.php.orig:0 0.0217 649072 2. error_handler() /usr/share/pear/pearcmd.php.orig:0 And many, many more Errors, as described before.

Comments

 [2008-03-24 06:48 UTC] cweiske (Christian Weiske)
PEAR supports PHP4, which does not have the instanceof operator.
 [2008-03-24 08:09 UTC] cellog (Greg Beaver)
this is a dupe of another valid bug, we need to add E_DEPRECATED to the error handler. It will be fixed.
 [2008-03-24 08:10 UTC] cellog (Greg Beaver)
my bad - this is the valid bug, re-opening
 [2008-03-24 08:20 UTC] hubbitus (Pavel Alexeev)
>PEAR supports PHP4, which does not have the instanceof operator. Ok, but it is not PHP5 compatible in this case! If you wish backward capabilities, as I wrote before, fast way is catch this "Deprecated" errors and safely ignore it.
 [2008-03-24 23:59 UTC] cellog (Greg Beaver)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.