Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.9.4

Bug #13047 PEAR fails to install *any* package
Submitted: 2008-02-02 14:46 UTC Modified: 2008-02-03 09:45 UTC
From: till Assigned: timj
Status: Closed Package: PEAR (version 1.7.0)
PHP Version: 5.2.3 OS: FreeBSD
Roadmaps: 1.7.1    
Subscription  


 [2008-02-02 14:46 UTC] till (Till Klampaeckel)
Description: ------------ Since I updated from PEAR-1.7.0RC2 to PEAR-1.7.0-stable I can't install any packages anymore. Test script: --------------- pear install --alldeps phpunit/phpUnderControl No releases available for package "pear.phpunit.de/phpUnderControl" Cannot initialize 'channel://pear.phpunit.de/phpUnderControl', invalid or missing package file Package "channel://pear.phpunit.de/phpUnderControl" is not valid install failed Expected result: ---------------- Installed package. Actual result: -------------- An error message, when I run with pear -vvvv, it gets more obvious: pear -vvvv install --alldeps phpunit/phpUnderControl Notice: Undefined offset: 1 in Console/Getopt.php on line 214 Notice: file_exists(): Unable to find the wrapper "channel" - did you forget to enable it when you configured PHP? in PEAR/Downloader/Package.php on line 1414 Notice: is_file(): Unable to find the wrapper "channel" - did you forget to enable it when you configured PHP? in PEAR/Downloader/Package.php on line 1423 Notice: is_file(): Unable to find the wrapper "channel" - did you forget to enable it when you configured PHP? in PEAR/Downloader/Package.php on line 1423 No releases available for package "pear.phpunit.de/phpUnderControl" Cannot initialize 'channel://pear.phpunit.de/phpUnderControl', invalid or missing package file Package "channel://pear.phpunit.de/phpUnderControl" is not valid install failed

Comments

 [2008-02-02 14:49 UTC] till (Till Klampaeckel)
Here is another example: pear upgrade Console_CommandLine Failed to download pear/Console_CommandLine within preferred state "stable", latest release is version 1.0.0RC1, stability "beta", use "channel://pear.php.net/Console_CommandLine-1.0.0RC1" to install Cannot initialize 'channel://pear.php.net/Console_CommandLine', invalid or missing package file Package "channel://pear.php.net/Console_CommandLine" is not valid upgrade failed Then: pear upgrade Console_CommandLine-beta downloading Console_CommandLine-1.0.0RC1.tgz ... Starting to download Console_CommandLine-1.0.0RC1.tgz (24,096 bytes) ........done: 24,096 bytes upgrade ok: channel://pear.php.net/Console_CommandLine-1.0.0RC1
 [2008-02-02 15:12 UTC] landure (Pierre-Yves Landuré)
Description: ------------ I can confirm this bug. OS : Debian 4.0 Etch PEAR version : 1.7.0 I've only got this problem with 1.7.0, before the same command was working well. here is what i get by trying to install imagick : Test script: --------------- pecl -vvv install imagick Expected result: ---------------- Installed package. Actual result: -------------- Notice: file_exists(): Unable to find the wrapper "channel" - did you forget to enable it when you configured PHP? in PEAR/Downloader/Package.php on line 1414 Notice: is_file(): Unable to find the wrapper "channel" - did you forget to enable it when you configured PHP? in PEAR/Downloader/Package.php on line 1423 Notice: is_file(): Unable to find the wrapper "channel" - did you forget to enable it when you configured PHP? in PEAR/Downloader/Package.php on line 1423 No releases available for package "pecl.php.net/imagick" Cannot initialize 'channel://pecl.php.net/imagick', invalid or missing package file Package "channel://pecl.php.net/imagick" is not valid install failed
 [2008-02-02 15:32 UTC] till (Till Klampaeckel)
I fixed it with "pear upgrade -f PEAR-1.7.0RC2". Since then it continues to work as expected.
 [2008-02-03 00:18 UTC] jausions (Philippe Jausions)
I don't know if it's related, but I had a similar problem with my own PEAR channel as well (http://pear.11abacus.com) I was getting 404 errors with PEAR 1.7.0 when trying to install/upgrade/anything remote. It was working fine with pear.php.net channel, but once I removed the duplicate "Host: " header sent by PEAR_REST::downloadHttp() (on line 325) in 1.7.0, I was able to install from my channel again. I'm running my PEAR channel on Debian Sarge with Apache 2.2.3 and Chiara_PEAR_Server_REST 1.8.0. The 404 error was occurring regardless of the system I was running the pear command (Windows XP or Debian)
 [2008-02-03 09:45 UTC] dufuz (Helgi Þormar Þorbjörnsson)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. The problem was actually already fixed in CVS by Tim but for some reason it wasn't synced into the REST file before the release even if it was included in the release notes.
 [2011-08-04 09:18 UTC] pzystorm (Kevin Richter)
This issue seems to be very up to date and must be reopened. Directly after the "make install" of php-5.3.6: rm /root/.pearrc /opt/php-5.3.6/bin/pear -vvv install apc Warning: file_exists(): Unable to find the wrapper "channel" - did you forget to enable it when you configured PHP? in PEAR/Downloader/Package.php on line 1518 Warning: is_file(): Unable to find the wrapper "channel" - did you forget to enable it when you configured PHP? in PEAR/Downloader/Package.php on line 1528 Warning: is_file(): Unable to find the wrapper "channel" - did you forget to enable it when you configured PHP? in PEAR/Downloader/Package.php on line 1528 No releases available for package "pear.php.net/apc" Cannot initialize 'channel://pear.php.net/apc', invalid or missing package file Package "channel://pear.php.net/apc" is not valid install failed # /opt/php-5.3.6/bin/pear -vvv upgrade PEAR Nothing to upgrade # /opt/php-5.3.6/bin/pear -vvv upgrade Nothing to upgrade I have no idea what to do.
 [2012-01-31 15:12 UTC] jochem (Jochem Meijers)
I had this same problem on a Windows machine, after reinstalling PHP. It was solved by emptying PEAR's cache (%TEMP%\pear\cache on a windows machine, probably /tmp/pear on *nix?). Mostly posting for reference purposes in case anyone else runs into this problem and finds this page (like I did).
 [2012-05-04 23:16 UTC] danomite (Danny Valente)
Thank you Jochem!! That's exactly what was my problem on Windows!
 [2013-05-27 06:38 UTC] sagar (Sagar Patil)
I am not able to Install packages pear install path_to_OLE_package install fail pear install OLE No releases available for package "pear.php.net/OLE" install failed