Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.6.0a3

Bug #13018 Curly bracket missing
Submitted: 2008-01-31 05:02 UTC Modified: 2008-01-31 15:36 UTC
From: bbrunekreeft Assigned: aidan
Status: Closed Package: PHP_Compat (version 1.6.0a1)
PHP Version: 5.0.4 OS: Fedora Core4
Roadmaps: 1.6.0a2, 1.6.0a1    
Subscription  


 [2008-01-31 05:02 UTC] bbrunekreeft (Bert Brunekreeft)
Description: ------------ Including PHP_Compat results in a parse error: PHP Parse error: parse error, unexpected $, expecting T_FUNCTION in /usr/share/pear/PHP/Compat.php on line 150 The problem is that a curly bracket is missing. A } has to be inserted at line 51 of Compat.php Test script: --------------- require_once 'PHP/Compat.php'; echo 'Hello'; Expected result: ---------------- 'Hello' get's echoed Actual result: -------------- parse error

Comments

 [2008-01-31 15:36 UTC] aidan (Aidan Lister)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.