Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.9.4

Bug #12945 PEAR_Registry::setConfig() does not set install path
Submitted: 2008-01-21 07:05 UTC Modified: 2008-05-13 23:16 UTC
From: cweiske Assigned: cellog
Status: Closed Package: PEAR (version 1.7.0RC2)
PHP Version: 5.2.5 OS:
Roadmaps: 1.7.2    
Subscription  


 [2008-01-21 07:05 UTC] cweiske (Christian Weiske)
Description: ------------ When using $pear_registry->setConfig() to change the configuration of an registry object, using getPackage() still fails because the registry relies on the install_dir set in the constructor. I expect the registry to use the installation directory of the current config -> patch attached.

Comments

 [2008-01-28 22:43 UTC] cellog (Greg Beaver)
Christian, this patch affects a critical portion of the core, and breaks 20 unit tests. I'm postponing until 1.7.1 at the earliest.
 [2008-05-13 23:16 UTC] cellog (Greg Beaver)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. I took your patch and added cleverness, making the reset of install_dir optional, enabled by default. This way, one can disable this for critical stuff like install_root and company. Voila, all existing tests pass with the change, so I'm happy :)