Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.26.0

Request #12786 Redesign of the menu system
Submitted: 2007-12-28 12:27 UTC Modified: 2007-12-30 18:46 UTC
From: dufuz Assigned: dufuz
Status: Closed Package: pearweb (version CVS)
PHP Version: Irrelevant OS: na
Roadmaps: 1.17.0    
Subscription  


 [2007-12-28 12:27 UTC] dufuz (Helgi Þormar Þorbjörnsson)
Description: ------------ At times the site has craved more space horizontally. By moving the top level and sub menu to the top we achieve this and thus have more space to play with and the site won't look so crammed on smaller displays. The manual will still require the menu on the left so that ability will still be around. This is what most of the site will look like: Header --------------------------- Top level menu --------------------------- Second level menu --------------------------- Main content Main content --------------------------- footer On the front page we will still keep the release right menu block.

Comments

 [2007-12-28 12:41 UTC] dufuz (Helgi Þormar Þorbjörnsson)
This feature depends on Request #12787 and Request #12788
 [2007-12-28 19:37 UTC] dufuz (Helgi Þormar Þorbjörnsson)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.
 [2007-12-29 05:45 UTC] wiesemann (Mark Wiesemann)
I like the new layout. But there are some issues: - visiting links are underlined while normal links are not underlined (just another color as in the current layout looks better) - the manual is ugly: http://tmp.markwiesemann.eu/pear-manual.png http://tmp.markwiesemann.eu/pear-manual2.png (only in IE, works in Firefox) => the left bar should have full height, the content shouldn't float around this bar - Firefox shows the list markers here: http://tmp.markwiesemann.eu/pear-pepr.png (IE doesn't show them)
 [2007-12-29 11:45 UTC] dufuz (Helgi Þormar Þorbjörnsson)
The manual part: Not a single person has been able to help me get it working in pearweb so I kept it on the side for now, I knew it was an area of ... interest :/ If you have a quick and dirty way, please email it to me :) The list thing, it doesn't happen for me, I develop using FF so I would notice but looking at my cvs modified list I see no CSS change that needs to go in, can you do a hard refresh ? This is what the CSS looks like for this tabbed list: #nav li { list-style-type: none; float: left; } So it should not show anything, hope it's the cache. About the visting link thing, I can't reproduce the behavior, do you mean after you've clicked the link it becomes underlined ?
 [2007-12-29 12:25 UTC] dufuz (Helgi Þormar Þorbjörnsson)
I hopefully addressed the links issue, not sure why I never saw visited links as anything different, now they look like they haven't been clicked, visited links are anyway a bit of, foobar IMHO
 [2007-12-30 18:46 UTC] dufuz (Helgi Þormar Þorbjörnsson)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. Everything should be fixed by now.