Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.26.0

Bug #12709 DB Error (syntax) transforming note into Doc bug
Submitted: 2007-12-17 18:25 UTC Modified: 2008-02-02 21:28 UTC
From: doconnor Assigned: davidc
Status: Closed Package: pearweb (version 1.16.3)
PHP Version: Irrelevant OS:
Roadmaps: 1.18.0, 1.17.0    
Subscription  


 [2007-12-17 18:25 UTC] doconnor (Daniel O'Connor)
Description: ------------ If you hit: http://pear.php.net/notes/admin/trans.php?action=makeDocBug&noteId=6793&url=package.text.text-wiki.intro.php You get: ERROR: * DB Error: syntax error

Comments

 [2007-12-17 18:27 UTC] doconnor (Daniel O'Connor)
Steps to reproduce: 1. Manage user notes 2. Choose a note 3. Transform into a doc bug
 [2007-12-18 12:59 UTC] wiesemann (Mark Wiesemann)
This works here. Daniel, was there anything special with that note? Special characters maybe?
 [2007-12-18 19:30 UTC] doconnor (Daniel O'Connor)
Note text is: " Can't view the online documentation !!?" You can see this by viewing deleted notes
 [2007-12-18 19:32 UTC] doconnor (Daniel O'Connor)
As a side note, the deleted notes page is a good example of why http://pear.php.net/bugs/bug.php?id=11865 is needed
 [2007-12-19 03:18 UTC] wiesemann (Mark Wiesemann)
> As a side note, the deleted notes page is a good example > of why http://pear.php.net/bugs/bug.php?id=11865 is needed It's IMHO an even better example for the need of implementing Request #11442.
 [2007-12-19 03:24 UTC] wiesemann (Mark Wiesemann)
I can't reproduce the problem with this text, neither here on pear.php.net nor on my local CVS version. David had added a mysql_escape_string(html_entity_decode()) call before the last pearweb release, and therefore the query shouldn't fail.
 [2008-02-02 21:28 UTC] dufuz (Helgi Þormar Þorbjörnsson)
Thank you for your bug report. This issue has been fixed in the latest released version of the package, which you can download at http://pear.php.net/get/pearweb No feedback was produced and according to Mark it might have been fixed. Reopen the bug if you have any problems like this again.