Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.9.4

Request #12706 pear list -a hard to read
Submitted: 2007-12-17 05:02 UTC Modified: 2008-07-12 09:47 UTC
From: shangxiao Assigned: dufuz
Status: Closed Package: PEAR (version 1.6.2)
PHP Version: 5.2.2 OS: Linux (Fedora)
Roadmaps: 1.8.0alpha1    
Subscription  


 [2007-12-17 05:02 UTC] shangxiao (David Sanders)
Description: ------------ Just a simple request: can we have a blank line below each section when doing a "pear list -a". At the moment it's hard to read. (see actual result) Actual result: -------------- Installed packages, channel __uri: ================================== (no packages installed) Installed packages, channel components.ez.no: ============================================= Package Version State Base 1.3 stable ConsoleTools 1.3 stable Installed packages, channel pear.assessments.com.au: ==================================================== Package Version State HTML_QuickForm_Rule_MIME_Type 0.1.0 alpha Installed packages, channel pear.php.net: ========================================= Package Version State Archive_Tar 1.3.2 stable Auth 1.5.4 stable Auth_HTTP 2.1.6 stable Config 1.10.11 stable

Comments

 [2008-01-01 15:04 UTC] dufuz (Helgi Þormar Þorbjörnsson)
As you pointed out, it's a request, not a bug :)
 [2008-01-07 00:00 UTC] shangxiao (David Sanders)
It could be classified as a bug in the visual sense, but I'm happy to leave it as a feature... as long as is doesn't drop off the radar, like requests tend to do for most projects... ;)
 [2008-01-15 06:13 UTC] rosier (Jan Rosier)
I did submit a patch. Is this output better?
 [2008-07-12 09:47 UTC] dufuz (Helgi Þormar Þorbjörnsson)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. Fixed, added spacing after each channel - also when the channel has no packages