Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.0.2

Bug #12653 Wrong HTTP Range: request header
Submitted: 2007-12-11 00:20 UTC Modified: 2008-01-08 11:26 UTC
From: kawai Assigned:
Status: Duplicate Package: HTTP_WebDAV_Client (version 0.9.7)
PHP Version: 5.2.4 OS: Windows
Roadmaps: (Not assigned)    
Subscription  


 [2007-12-11 00:20 UTC] kawai (Hiroaki Kawai)
Description: ------------ The library generates wrong Range: bytes=START-END HTTP header. So, I got the following message in the PHP error_log: HTTP_WebDAV_Client_Stream::stream_read - read 1 bytes more data than requested (8193 read, 8192 max) - excess data will be lost RFC2616 section 14.16 says: . The first 500 bytes: bytes 0-499/1234 . The second 500 bytes: bytes 500-999/1234 . All except for the first 500 bytes: bytes 500-1233/1234 . The last 500 bytes: bytes 734-1233/1234 Test script: --------------- require_once('./HTTP/WebDAV/Client.php'); echo file_get_contents('webdav://192.168.0.74/test/10.jpg','rb'); Expected result: ---------------- THE CONTENTS OF THE FILE Actual result: -------------- Warning: file_get_contents() [function.file-get-contents]: HTTP_WebDAV_Client_Stream::stream_read - read 1 bytes more data than requested (8193 read, 8192 max) - excess data will be lost in D:\apache\front\htdocs\c\c.php on line 4

Comments

 [2008-01-08 10:10 UTC] schmidt (Christian Schmidt)
The patch looks good to.
 [2008-01-08 11:26 UTC] hholzgra (Hartmut Holzgraefe)
Duplicate of Bug #6407, fix will be in upcoming release later today