Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 2.4.2

Request #12532 Add addional info to apc5 "info"
Submitted: 2007-11-26 18:07 UTC Modified: 2008-04-21 17:45 UTC
From: sgirard Assigned: farell
Status: Closed Package: HTML_Progress2 (version 2.3.0)
PHP Version: 5.2.4 OS: NA
Roadmaps: 2.4.0    
Subscription  


 [2007-11-26 18:07 UTC] sgirard (Sean Girard)
Description: ------------ I finally took the time to figure out the apc uploader and it's great. I have what I think is a simple request. I would like to have some additional info stashed in the getInfo() array in Upload.php... the type of stuff you get with the $_FILES variable. Basic idea is that you might want to report back to the user (or use elsewhere in your script) information relating to the file name, mime type, etc. Obviously this is a feature request, not a bug. If you like the idea use it, if not, no big deal. Thanks, -sean Test script: --------------- I added: $info['apc_fetch'] = $tmp; after line 158 in Upload.php, which at least gets me the file name and that's good enough for me at this point.

Comments

 [2008-04-19 12:44 UTC] farell (Laurent Laville)
Sorry Sean to take so much time to implement your request: Could you have a look on latest commit on PEAR CVS, and tell me if it match what you want , please . Checkout files : Progress2/Upload.php examples/ajax/upload/auto_server.php examples/ajax/upload/apc5_upload3.php <-- demo which display current file name
 [2008-04-21 10:19 UTC] sgirard (Sean Girard)
I took a quick look at your implementation of my request and it looks fine to me. I will adjust my current project to use this rather than my patch. Thank you very much for fitting it in and also for the apc uploader in general... it almost seems a shame to have such a great feature buried under another package. -sean
 [2008-04-21 17:45 UTC] farell (Laurent Laville)
I've also added some new format to display additional info, such as %S - speed limit %E - time left to %F - current filename A new example using UPM5 backend (uploadprogress extension) in examples/ajax/upload/upm5_upload.php demonstrate these new formats Hope you will enjoy it !