Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.5.2

Bug #12439 Log using VERSIONCONTROL_SVN_FETCHMODE_ARRAY fails
Submitted: 2007-11-13 20:42 UTC Modified: 2009-08-09 18:41 UTC
From: justinpatrin Assigned: mrook
Status: Closed Package: VersionControl_SVN (version 0.3.1)
PHP Version: 5.2.3 OS:
Roadmaps: 0.3.2    
Subscription  


 [2007-11-13 20:42 UTC] justinpatrin (Justin Patrin)
Description: ------------ If you set the fetchmode to VERSIONCONTROL_SVN_FETCHMODE_ARRAY the response is always empty. This is due to the code that adds the --xml switch not checking for $fetchmode == VERSIONCONTROL_SVN_FETCHMODE_ARRAY.

Comments

 [2008-01-10 22:25 UTC] robsharp (Rob Sharp)
Hi Justin, Which subversion command are you executing? Looking at the comments on the prepare() method in the Info class, VERSIONCONTROL_SVN_FETCHMODE_ARRAY shouldn't use --xml mode, I assume it should simply explode the raw command output on the newline character. Could you provide example code, please? Thanks, Rob.
 [2009-08-09 18:34 UTC] mrook (Michiel Rook)
-Status: Open +Status: Assigned -Assigned To: +Assigned To: mrook
 [2009-08-09 18:41 UTC] mrook (Michiel Rook)
-Status: Assigned +Status: Closed
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.