Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 2.1.0

Bug #12316 PEAR is no longer the default standard
Submitted: 2007-10-23 16:31 UTC Modified: 2007-10-28 22:13 UTC
From: cwiedmann Assigned: squiz
Status: Closed Package: PHP_CodeSniffer (version 0.9.0)
PHP Version: Irrelevant OS: Windows_NT
Roadmaps: 1.0.0RC1    
Subscription  


 [2007-10-23 16:31 UTC] cwiedmann (Carsten Wiedmann)
Description: ------------ Hello, in the current package the default config file is missing. You are using this file in "PHP/CodeSniffer.php" line 1374 (getAllConfigData). This file should have the content: | <?php | $phpCodeSnifferConfig = array ( | 'default_standard' => 'PEAR', | ) | ?> Regards, Carsten Test script: --------------- If I make a fresh install with: | pear install PHP_CodeSniffer And than make a sniff with: | phpcs foo.php Expected result: ---------------- A correct result, because 'PEAR' should be (is) the default standard. Actual result: -------------- ERROR: You must supply the name of the coding standard to use.

Comments

 [2007-10-23 17:06 UTC] squiz (Greg Sherwood)
Thank you for taking the time to report a problem with the package. This problem may have been already fixed by a previous change that is in the CVS of the package. Please log into CVS with: cvs -d :pserver:cvsread@cvs.php.net:/repository login and check out the CVS repository of this package and upgrade cvs -d :pserver:cvsread@cvs.php.net:/repository co pear/PHP_CodeSniffer pear upgrade pear/PHP_CodeSniffer/package2.xml or pear upgrade pear/PHP_CodeSniffer/package.xml If you are able to reproduce the bug with the latest CVS, please change the status back to "Open". Again, thank you for your continued support of PEAR. I noticed this last week and fixed it in CVS. The config file should still be empty, but I accidentally removed the code that set PEAR as the default if the config setting does not exist.
 [2007-10-23 17:38 UTC] cwiedmann (Carsten Wiedmann)
| This problem may have been already fixed by a previous | change that is in the CVS of the package. I can confirm that. With the version from CVS the error don't occur. Regards, Carsten