Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 2.4.8

Bug #12257 Strict Standards error messages from pager.
Submitted: 2007-10-16 08:57 UTC Modified: 2007-10-16 15:40 UTC
From: naujocke Assigned: quipo
Status: Closed Package: Pager (version 2.4.4)
PHP Version: 5.2.0 OS: Linux
Roadmaps: (Not assigned)    
Subscription  


 [2007-10-16 08:57 UTC] naujocke (Eric Naujock)
Description: ------------ The following errors occur when running pager in php 5.2.0 Test script: --------------- Strict Standards: Assigning the return value of new by reference is deprecated in /.renv/usr/local/lib/pear/Pager.php on line 183 Strict Standards: Non-static method Pager::factory() should not be called statically, assuming $this from incompatible context in /htdocs/newsite/application/controllers/SheriffsaleController.php on line 392 Strict Standards: Assigning the return value of new by reference is deprecated in /.renv/usr/local/lib/pear/Pager/Common.php on line 1151 Strict Standards: Assigning the return value of new by reference is deprecated in /.renv/usr/local/lib/pear/Pager/Common.php on line 1175 Strict Standards: Declaration of Pager_Sliding::getPageIdByOffset() should be compatible with that of Pager_Common::getPageIdByOffset() in /.renv/usr/local/lib/pear/Pager/Sliding.php on line 55 Strict Standards: Declaration of Pager_Sliding::getPageRangeByPageId() should be compatible with that of Pager_Common::getPageRangeByPageId() in /.renv/usr/local/lib/pear/Pager/Sliding.php on line 55 Strict Standards: Declaration of Pager_Sliding::getLinks() should be compatible with that of Pager_Common::getLinks() in /.renv/usr/local/lib/pear/Pager/Sliding.php on line 55 Expected result: ----------------

Comments

 [2007-10-16 15:40 UTC] quipo (Lorenzo Alberton)
I fixed a few of those. The remaining ones are due to PHP4 compatibility, which must be preserved.