Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.8.8

Bug #12165 Dot at the end of the line disappeared
Submitted: 2007-10-01 12:25 UTC Modified: 2007-10-06 07:51 UTC
From: mhussain Assigned: cipri
Status: Closed Package: Mail_Mime (version CVS)
PHP Version: 4.4.4 OS: Ubuntu Linux
Roadmaps: 1.5.3    
Subscription  


 [2007-10-01 12:25 UTC] mhussain (Mohannad Hussain)
Description: ------------ We are using this package for a newsletter module, and for one client we noticed one of the links would not work, the link should be http://theachievementcentre.com but it comes up as: http://theachievementcentrecom (missing the dot) I traced this issue to the mime.php in the Mail package, it seems to dot has been lost because it was at the end of the line being trimmed, here is a snapshot from the message: n: center; text-decoration: underline;' href=3D'http://theachievementcentre= com/newsletter/view/?dist_id=3Df&display=3Dsendfriend&issue_id=3D274&em_id= =3D19640'>Send to a Friend
<div style=3D'font-weight: normal; font= We tried upgrading the CVS version of the package but it didn't seem to have any effect. Test script: --------------- $string='http://aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa.com' $mime = new Mail_mime(); $mime->setHTMLBody($string); mail('me@example.com','test',$mime->get(),$mime->headers($hdrs));

Comments

 [2007-10-05 17:31 UTC] cipri (Cipriano Groenendal)
Sorry, but your problem does not imply a bug in PEAR itself. For a list of more appropriate places to ask for help using PEAR, please visit http://pear.php.net/support/ as this bug system is not the appropriate forum for asking support questions. Thank you for your interest in PEAR. I added the following code to your example: var_dump($mime->get()); This shows that the . is actually the first character on the next line, not the last on the first line. As such, this problem is most likely caused by your mailserver incorrectly interpreting the . on the beginning of the line as an escape character. I would suggest either updating your mailserver software, or changing the method you use to send the mail, IE use PEAR's Mail package and deliver to SMTP instead of the mail() function.
 [2007-10-06 07:51 UTC] cipri (Cipriano Groenendal)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. This problem was actually fixed in the most recent package, and was fully fixed in CVS, and will be included in Mail_Mime-1.5.3