Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.9.4

Bug #11861 uninstall of package did not delete directory created during install of package
Submitted: 2007-08-18 11:09 UTC Modified: 2007-08-31 17:06 UTC
From: kguest Assigned: cellog
Status: Closed Package: PEAR (version 1.6.1)
PHP Version: 5.1.6 OS: Ubuntu Linux
Roadmaps: 1.6.2    
Subscription  


 [2007-08-18 11:09 UTC] kguest (Ken Guest)
Description: ------------ installed Validate_NZ from local package XML file, then later on uninstalled the package. Found that a directory created during the install of that package still existed was still present after the uninstall. Test script: --------------- #prove that the directory does not exist before the test $ ls /usr/share/pear/tests/Validate_NZ/ ls: /usr/share/pear/tests/Validate_NZ/: No such file or directory $ sudo pear install ~/pear/Validate/package_NZ.xml install ok: channel://pear.php.net/Validate_NZ-0.1.2 $ ls /usr/share/pear/tests/Validate_NZ/ tests $ sudo pear uninstall Validate_NZ uninstall ok: channel://pear.php.net/Validate_NZ-0.1.2 $ ls -d /usr/share/pear/tests/Validate_NZ/ /usr/share/pear/tests/Validate_NZ/ Expected result: ---------------- would have expected the /usr/share/pear/tests/Validate_NZ/ directory would have been deleted and the last 'ls' command to have displayed an error message. Actual result: -------------- /usr/share/pear/tests/Validate_NZ/ directory remains after uninstall, although it should not.

Comments

 [2007-08-31 17:06 UTC] cellog (Greg Beaver)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.