Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.0.2

Bug #11815 XML_Parser must be installed manually
Submitted: 2007-08-10 15:08 UTC Modified: 2008-12-20 08:31 UTC
From: ikkiphenix Assigned: doconnor
Status: Closed Package: XML_RSS
PHP Version: 5.2.3 OS: Windows XP SP2
Roadmaps: (Not assigned)    
Subscription  


 [2007-08-10 15:08 UTC] ikkiphenix (Xavier Blanchet)
Description: ------------ The documentation says "To parse the XML files that contain the RSS feeds, XML_RSS requires that the package XML_Parser is installed. However this dependency will be automatically handled by the installer during the installation phase of XML_RSS. But no, it seems that XML_Parser must be installed manually, even if we use --alldeps ... -- Pear 1.6.1 PHP 5.2.3 Windows XP SP2 Test script: --------------- pear install --alldeps XML_RSS Expected result: ---------------- [...] install ok: channel://pear.php.net/XML_Parser-1.2.8 [...]

Comments

 [2007-10-31 10:17 UTC] cweiske (Christian Weiske)
Seems to be a bug in pear cmdline tool. When I convert the package to use package.xml v2 and install this package, XML_Parser gets installed.
 [2007-11-04 16:05 UTC] cellog (Greg Beaver)
Thank you for taking the time to report a problem with the package. Unfortunately you are not using a current version of the package -- the problem might already be fixed. Please download a new version from http://pear.php.net/packages.php If you are able to reproduce the bug with one of the latest versions, please change the package version on this bug report to the version you tested and change the status back to "Open". Again, thank you for your continued support of PEAR.
 [2007-11-23 10:59 UTC] cellog (Greg Beaver)
I cannot reproduce this, and there is no feedback.
 [2007-11-23 13:56 UTC] cweiske (Christian Weiske)
The current version of XML_RSS has no dependencies on XML_Parser listed in package.xml - although the class extends XML_Parser. I'll open a bug.
 [2007-11-23 13:58 UTC] cweiske (Christian Weiske)
Damn me. $ pear install --alldeps xml_rss-beta works fine
 [2007-11-23 14:26 UTC] ikkiphenix (Xavier Blanchet)
Yes, exactly ! I have just tested it. $ pear install --alldeps xml_rss-beta works fine but $ pear install --alldeps xml_rss does not...
 [2007-11-23 15:24 UTC] cellog (Greg Beaver)
problem tracked down. XML_RSS version 0.9.10 is beta, and XML_RSS version 0.9.2 is stable When you have preferred_state set to "stable" it downloads 0.9.2, which has no dependency on XML_Parser in package.xml When you have preferred_state set to "beta" it downloads 0.9.10, which then has the required dependency on XML_Parser You need to remove the 0.9.2 release, add the XML_Parser dependency and re-release it as beta, or simply leave it removed, and the problem will disappear
 [2008-12-20 08:31 UTC] doconnor (Daniel O'Connor)
Fixed - removed the 0.9.2 and lower releases which were marked as stable with MJ's OK.