Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.9.5

Bug #11754 Error at upgrade-all command run
Submitted: 2007-08-04 10:52 UTC Modified: 2007-08-18 17:54 UTC
From: cms Assigned: cellog
Status: Closed Package: PEAR (version 1.6.1)
PHP Version: 5.2.1 OS: Linux 2.6.20
Roadmaps: 1.6.2    
Subscription  


 [2007-08-04 10:52 UTC] cms (Carl Michael Skog)
Description: ------------ This error reulted from a 'upgrade-all' command run on Saturday Aug 4 17:40 CEST 2007 with the 'xdebug' extension enabled. $ sudo pear upgrade-all Will upgrade channel://pear.phpunit.de/phpunit Warning: version_compare() expects parameter 1 to be string, array given in PEAR/Downloader.php on line 827 Warning: version_compare() expects parameter 1 to be string, array given in /usr/share/php/PEAR/Downloader.php on line 827 Call Stack: 0.0270 241432 1. {main}() /usr/share/php/pearcmd.php:0 1.3776 2910192 2. PEAR_Command_Common->run() /usr/share/php/pearcmd.php:312 1.3776 2910192 3. PEAR_Command_Install->doUpgradeAll() /usr/share/php/PEAR/Command/Common.php:285 1.5512 2943500 4. PEAR_Command_Install->doInstall() /usr/share/php/PEAR/Command/Install.php:830 105.7055 5688604 5. PEAR_Downloader->download() /usr/share/php/PEAR/Command/Install.php:624 105.7655 6223344 6. PEAR_Downloader_Package->initialize() /usr/share/php/PEAR/Downloader.php:280 105.7675 6223988 7. PEAR_Downloader_Package->_fromString() /usr/share/php/PEAR/Downloader/Package.php:185 105.7750 6227284 8. PEAR_Downloader->_getPackageDownloadUrl() /usr/share/php/PEAR/Downloader/Package.php:1617 110.4231 6712332 9. version_compare() /usr/share/php/PEAR/Downloader.php:827 Failed to download phpunit/phpunit within preferred state "stable", latest release is version , stability "", use "channel://pear.phpunit.de/phpunit" to install Cannot initialize 'channel://pear.phpunit.de/phpunit', invalid or missing package file Package "channel://pear.phpunit.de/phpunit" is not valid upgrade-all failed Test script: --------------- Run a 'upgrade-all' PEAR command. Expected result: ---------------- The command should run without error. Actual result: -------------- $ sudo pear upgrade-all Will upgrade channel://pear.phpunit.de/phpunit Warning: version_compare() expects parameter 1 to be string, array given in PEAR/Downloader.php on line 827 Warning: version_compare() expects parameter 1 to be string, array given in /usr/share/php/PEAR/Downloader.php on line 827 Call Stack: 0.0270 241432 1. {main}() /usr/share/php/pearcmd.php:0 1.3776 2910192 2. PEAR_Command_Common->run() /usr/share/php/pearcmd.php:312 1.3776 2910192 3. PEAR_Command_Install->doUpgradeAll() /usr/share/php/PEAR/Command/Common.php:285 1.5512 2943500 4. PEAR_Command_Install->doInstall() /usr/share/php/PEAR/Command/Install.php:830 105.7055 5688604 5. PEAR_Downloader->download() /usr/share/php/PEAR/Command/Install.php:624 105.7655 6223344 6. PEAR_Downloader_Package->initialize() /usr/share/php/PEAR/Downloader.php:280 105.7675 6223988 7. PEAR_Downloader_Package->_fromString() /usr/share/php/PEAR/Downloader/Package.php:185 105.7750 6227284 8. PEAR_Downloader->_getPackageDownloadUrl() /usr/share/php/PEAR/Downloader/Package.php:1617 110.4231 6712332 9. version_compare() /usr/share/php/PEAR/Downloader.php:827 Failed to download phpunit/phpunit within preferred state "stable", latest release is version , stability "", use "channel://pear.phpunit.de/phpunit" to install Cannot initialize 'channel://pear.phpunit.de/phpunit', invalid or missing package file Package "channel://pear.phpunit.de/phpunit" is not valid upgrade-all failed

Comments

 [2007-08-18 17:54 UTC] cellog (Greg Beaver)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.