Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 2.5.0b5

Bug #11753 Notice: Undefined index: default in Manager\pgsql.php on line 294
Submitted: 2007-08-04 02:52 UTC Modified: 2007-08-04 03:13 UTC
From: floele Assigned: quipo
Status: Closed Package: MDB2 (version CVS)
PHP Version: Irrelevant OS: Irrelevant
Roadmaps: (Not assigned)    
Subscription  


 [2007-08-04 02:52 UTC] floele (Florian Schmitz)
Description: ------------ Hi. When verifying bug 11694, I found a new bug. During database update, the following message appears multiple times: Notice: Undefined index: default in Manager\pgsql.php on line 294 The problem is that it checks for $field['default'] in line 293 but actally uses $field['definition']['default'] after that. Test script: --------------- Example array: array(2) { ["default"]=> bool(true) ["definition"]=> array(4) { ["type"]=> string(4) "text" ["length"]=> string(2) "50" ["notnull"]=> bool(true) ["was"]=> string(10) "field_name" } }

Comments

 [2007-08-04 03:13 UTC] quipo (Lorenzo Alberton)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. -- $field['definition']['default'] is the correct syntax