Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.5.0a1

Bug #11613 -q flag is not honoured
Submitted: 2007-07-16 09:20 UTC Modified: 2007-12-07 20:32 UTC
From: till Assigned: ashnazg
Status: Closed Package: PhpDocumentor (version 1.4.0RC2)
PHP Version: 5.2.2 OS: Gentoo
Roadmaps: 1.4.1    
Subscription  


 [2007-07-16 09:20 UTC] till (Till Klampaeckel)
Description: ------------ phpdoc -q Still shows all the output. phpdoc -q on Works as expected. Expected result: ---------------- No output. Actual result: -------------- A lot of output.

Comments

 [2007-07-20 08:40 UTC] ashnazg (Chuck Burgess)
Verified this. Looks like this condition of "flag given with no value" will result in "ERROR: command quiet was passed "-pp" but must be one of..." if there is another flag given after it, but this error does not get triggered if the flag is the last item on the commandline. So, "phpdoc -q -pp" would trigger the above error, and "phpdoc -pp -q" would trigger the same error about the "-pp" value, but "phpdoc -q" does not trigger an error. I need to review the arg parsing logic. I had fixed it previously so that it would recognize empty arg values and treat them as "on", and it does work as "phpdoc -q '' -pp '' " , but that doesn't seem to work like I'd wanted it to for just "phpdoc -q -pp".
 [2007-07-21 04:58 UTC] till (Till Klampaeckel)
Thanks for the heads up.
 [2007-12-07 20:30 UTC] ashnazg (Chuck Burgess)
Worked on this bug today. Got it working on Windows, then tested the change on Ubuntu and OS X (PHP4). Also, my regression test setup on Ubuntu (PHP 5.2.5) shows no side-effects. This change handles the scenario of "arg option given but no arg value given", both when the arg in question is followed by another arg option: - phpdoc -d . -t ./docs -q -pp -ue or when the arg option is the last item in the command: - phpdoc -d . -t ./docs -q on -pp off -ue
 [2007-12-07 20:32 UTC] ashnazg (Chuck Burgess)
Committed to CVS.