Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.26.0

Bug #11534 API docs are missing for some packages
Submitted: 2007-07-05 11:34 UTC Modified: 2007-07-25 12:12 UTC
From: saltybeagle Assigned: mj
Status: Closed Package: pearweb
PHP Version: Irrelevant OS:
Roadmaps: (Not assigned)    
Subscription  


 [2007-07-05 11:34 UTC] saltybeagle (Brett Bieber)
Description: ------------ The API documentation for PHP_CodeSniffer at http://pear.php.net/package/PHP_CodeSniffer/docs/latest/ and all docs since 0.2.0 have not been built.

Comments

 [2007-07-07 06:58 UTC] wiesemann (Mark Wiesemann)
API docs are also missing for I18N_UnicodeNormalizer.
 [2007-07-23 08:50 UTC] mj (Martin Jansen)
In case of PHP_CodeSniffer, the problem is related to errors in the API doc markup: ERROR in ClassCommentUnitTest.inc on line 80: DocBlock has multiple @package tags, illegal. ignoring additional tag "@package ADDITIONAL PACKAGE TAG" ERROR in FileCommentUnitTest.inc on line 38: DocBlock has multiple @package tags, illegal. ignoring additional tag "@package ADDITIONAL PACKAGE TAG" ERROR in FunctionCommentUnitTest.inc on line 16: "@return" tag was used without any parameters, illegal ERROR in FunctionCommentUnitTest.inc on line 127: "@return" tag was used without any parameters, illegal ERROR in FunctionCommentUnitTest.inc on line 127: "@param" tag was used without any parameters, illegal ERROR in LowercaseClassKeywordsUnitTest.inc on line 1: class MyClass cannot extend itself - TEST YOUR CODE BEFORE PARSING ERROR in LowercaseClassKeywordsUnitTest.inc on line 1: class MyClass cannot extend itself - TEST YOUR CODE BEFORE PARSING I'm assigning this to PHP_CodeSniffer so that it can be fixed there.
 [2007-07-23 17:38 UTC] squiz (Greg Sherwood)
I cannot fix these errors. These errors are in my unit tests files and must be there so PHP_CodeSniffer can find and report on the errors in the docblocks. If I remove these particular errors so the docs can run, PHP_CodeSniffer would no longer be testing for some cases, so that is not an acceptable solution.
 [2007-07-24 09:26 UTC] wiesemann (Mark Wiesemann)
Greg, how about excluding the tests/ directory? This seems to be the solution for the API docs of I18N_UnicodeNormalizer.
 [2007-07-24 17:36 UTC] squiz (Greg Sherwood)
How do I exclude the tests directory? I'd be very happy to do it if you can tell me how.
 [2007-07-25 04:45 UTC] wiesemann (Mark Wiesemann)
Martin can do that for you. He excluded the data/ directory globally for all packages, and could do the same thing maybe just for your package (or for all packages) for the tests/ directory. I wouldn't consider the tests/ directory as very important for the API docs.
 [2007-07-25 12:12 UTC] wiesemann (Mark Wiesemann)
Assigning to Martin and back to pearweb ... (=> closed)