Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.2.4

Bug #11399 img tags don't work
Submitted: 2007-06-22 03:50 UTC Modified: 2007-07-02 11:43 UTC
From: avoid Assigned:
Status: Bogus Package: HTML_BBCodeParser (version 1.2.1)
PHP Version: 5.2.1 OS: Suse Linux
Roadmaps: (Not assigned)    
Subscription  


 [2007-06-22 03:50 UTC] avoid (Arjan Haverkamp)
Description: ------------ Feeding the parser with the following code does not work: [img]http://www.mysite.com/images/logo.gif[/img] Same for this one: [img w=80 h=25]http://www.mysite.com/images/logo.gif[/img] I am using this ini file: [HTML_BBCodeParser] filters = Basic,Extended,Links,Images,Lists,Email Expected result: ---------------- <img src="http://www.mysite.com/images/logo.gif" /> <img src="http://www.mysite.com/images/logo.gif" width="80" height="25" /> Actual result: -------------- [img=<a href="http://www.mysite.com/images/logo.gif">http://www.mysite.com/images/logo.gif</a>] [img=<a href="http://www.mysite.com/images/logo.gif">http://www.mysite.com/images/logo.gif</a> w=80 h=25]

Comments

 [2007-06-22 04:18 UTC] avoid (Arjan Haverkamp)
The problem only arises when both the Links and Images filters are enabled. When only Images is enabled, it does seem to work okay. Still quite a bug though...
 [2007-06-27 09:40 UTC] meuledor (Pierre-Julien Margotin)
I had the same problem and I just understood why: The class parse your string in the order of filter. So change: [HTML_BBCodeParser] filters = Basic,Extended,Links,Images,Lists,Email To [HTML_BBCodeParser] filters = Basic,Extended,Images,Links,Lists,Email and images parsing will works ;) Meuledor - fqp team
 [2007-07-02 11:43 UTC] cweiske (Christian Weiske)
Seems there is a solution.