Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.8.9

Bug #11381 domain name is attached to content-id, trailing greater-than sign is not remove
Submitted: 2007-06-21 03:05 UTC Modified: 2007-06-21 14:01 UTC
From: lxg Assigned: cipri
Status: Closed Package: Mail_Mime (version 1.5.1)
PHP Version: 5.2.2 OS: Linux
Roadmaps: 1.5.2    
Subscription  


 [2007-06-21 03:05 UTC] lxg (Alex Gunshot)
Description: ------------ when adding an image to a message, a content-id is added to the attachment "header". But there is the domain name of the sender attached to the content-id. This for itself is not problematic, but a trailing greater-than sign (closing pointed bracket) from the e-mail address is not removed. This makes the HTML invalid as soon as the references are automatically replaced. See ll. 642-647 in v 1.5.1. Expected result: ---------------- Content-ID without domain name is generated and properly inserted. Or: Domain name is properly extracted. Actual result: -------------- see above

Comments

 [2007-06-21 14:01 UTC] cipri (Cipriano Groenendal)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. There'll be a 1.5.2 out in a few minutes, thanks for the bug report!
 [2007-07-25 06:32 UTC] ndrs (Andrius Whatever)
The problem is still there... The '@' symbol gets encoded, and I think it gets decoded by the mail client and not matched up to the cid on MIME. I added '@' to removed characters and it seems to solve the problem. mime.php, Line 645 //Bug #11381: Illegal characters in domain ID $domain = str_replace(array("@", "<", ">", "&", "(", ")", " ", "\"", "'"), "", $domain);