Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.26.0

Bug #11295 Fixed in CVS does not mark a bug as closed
Submitted: 2007-06-12 10:00 UTC Modified: 2007-08-11 17:51 UTC
From: cellog Assigned: dufuz
Status: Closed Package: pearweb
PHP Version: 5.2.2 OS:
Roadmaps: 1.17.0    
Subscription  


 [2007-06-12 10:00 UTC] cellog (Greg Beaver)
Description: ------------ when choosing the "Fixed in CVS" option, it no longer marks a bug as closed, which is really annoying.

Comments

 [2007-06-12 13:29 UTC] wiesemann (Mark Wiesemann)
This works both in local pearweb installation and also on pear.php.net for me. But I had a similar issue this morning when I tried to mark request #11292 as a duplicate: after the first submit, the bug had still the "Open" status.
 [2007-06-12 15:51 UTC] dufuz (Helgi Þormar)
I actually noticed this couple of time, I just blamed it on the fact I was pulling a 24 hour day and kept on going ... Didn't give it a second thought because it worked in 99% of the cases for me to mark it fixed in cvs and it closed right away
 [2007-06-18 21:08 UTC] cellog (Greg Beaver)
I haven't been able to reproduce this one in a while. I think something else must have fixed it
 [2007-06-26 16:12 UTC] dufuz (Helgi Þormar)
this has been reproduced by both me and greg, kinda, we now have to find a solid way to reproduce it every single time. move bug to assigned, submit, then use auto message to close the bug again and see if it moves to open like Greg just encountered
 [2007-08-04 14:21 UTC] wiesemann (Mark Wiesemann)
I could reproduce the problem Helgi's description multiple times locally. The problem seems to be the check in line 439 of bug.php. Removing this check (which doesn't make much sense IMHO) resolves the problem, the bug is closed as expected with the quick fix option. I'll attach a patch.
 [2007-08-11 17:51 UTC] dufuz (Helgi Þormar)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.