Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.26.0

Bug #11192 Bug comments create wrong links to other bugs
Submitted: 2007-05-31 15:29 UTC Modified: 2007-06-09 13:43 UTC
From: cipri Assigned: dufuz
Status: Closed Package: pearweb (version 1.15.2)
PHP Version: Irrelevant OS: Irrelevant
Roadmaps: 1.16.1    
Subscription  


 [2007-05-31 15:29 UTC] cipri (Cipriano Groenendal)
Description: ------------ The Bug system finds links to other bugs (ie: Bug #11192) across multiple lines when it shouldn't. Test script: --------------- 1) New feature 2) New bug 3) End of test

Comments

 [2007-05-31 15:44 UTC] wiesemann (Mark Wiesemann)
The patch breaks the current behaviour when there is a linebreak between e.g. "Bug" and the number, e.g. caused by the linebreaks that the bug tracker adds. Example: .... ....... .... Bug #123 .... .... (no link would be generated with the patch applied) Wouldn't it be better to require the "#" symbol? Isn't this the common notation? I can't remember a reference like "Bug 123".
 [2007-06-09 13:43 UTC] dufuz (Helgi ├×ormar)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.