Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.26.0

Bug #11180 User note's timestamp is updated on approval
Submitted: 2007-05-30 16:20 UTC Modified: 2008-01-21 15:26 UTC
From: wiesemann Assigned: cellog
Status: Closed Package: pearweb (version CVS)
PHP Version: 5.2.1 OS:
Roadmaps: 1.18.0, 1.17.0    
Subscription  


 [2007-05-30 16:20 UTC] wiesemann (Mark Wiesemann)
Description: ------------ When user notes in the manual are approved, the timestamp is updated. This is a problem e.g. on the following page: http://pear.php.net/manual/en/package.fileformats.spreadsheet-excel-writer.spreadsheet-excel-writer-worksheet.writestring.php The user submitted his note two days before (May 28th), Craig answered it in a new note (but didn't approve the original note) on May 30th. Now I have approved the note, and the timestamp was updated. Unfortunately, the order of the two notes is now wrong. (Not really a problem here, but with more notes on the page, the right order would be more helpful.)

Comments

 [2007-06-09 21:43 UTC] dufuz (Helgi Þormar)
Here's the problem, someone snuck in a ON UPDATE CURRENT_TIMESTAMP for the note_time field yet it's not in the sql / xml files for pearweb. Now we have to wait for some sys admin to remove that from manual_notes.
 [2007-06-10 19:34 UTC] dufuz (Helgi Þormar)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.
 [2007-07-20 15:06 UTC] wiesemann (Mark Wiesemann)
This is not fixed in the database, the timestamp is still updated to the current time.
 [2007-08-12 13:28 UTC] dufuz (Helgi Þormar)
Dang, that's weird, I'll try to look into this before the next release.
 [2007-11-04 13:51 UTC] cweiske (Christian Weiske)
still in the database.
 [2007-12-18 13:06 UTC] wiesemann (Mark Wiesemann)
This needs to fixed by somebody that has access to the PEAR database. Greg or Martin, can you please look into the database and fix this problem? (This is currently the last open problem scheduled for the next release of pearweb.)
 [2008-01-03 13:34 UTC] cellog (Greg Beaver)
Thank you for your bug report. This issue has been fixed in the latest released version of the package, which you can download at http://pear.php.net/get/pearweb
 [2008-01-07 07:25 UTC] wiesemann (Mark Wiesemann)
Re-opening, as this is still not fixed.
 [2008-01-08 05:32 UTC] dufuz (Helgi Þormar Þorbjörnsson)
Then the issue is something else than in the database, Greg did a alter statement on that field and even showed me so we've be sure nothing went wrong in that. I guess someone has to comb that note class David wrote.
 [2008-01-08 06:09 UTC] wiesemann (Mark Wiesemann)
> Then the issue is something else than in the database, > Greg did a alter statement on that field and even showed > me so we've be sure nothing went wrong in that. I tried it in my local installation: I've approved an unapproved note from somewhere in December. The timestamp remained the same. In the notes class there is no UPDATE SQL query that changes the note_time field. This field is only used in SELECT and INSERT queries. Therefore, this still seems to be an issue in the database. Greg, did you modify the right table? It's manual_notes, not just notes.
 [2008-01-21 15:23 UTC] dufuz (Helgi Þormar Þorbjörnsson)
Greg changed the database field to datetime like you suggested, could you recheck ?
 [2008-01-21 15:26 UTC] wiesemann (Mark Wiesemann)
Perfect, it works now. The timestamp doesn't get updated anymore.