Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.5.7

Bug #10973 package.xml does not replace '@data-dir@'
Submitted: 2007-05-07 14:15 UTC Modified: 2007-05-07 15:01 UTC
From: atex Assigned: jeichorn
Status: Closed Package: HTML_AJAX (version 0.5.1)
PHP Version: 5.2.0 OS:
Roadmaps: (Not assigned)    
Subscription  


 [2007-05-07 14:15 UTC] atex (Andrew Teixeira)
Description: ------------ Between version 0.5.0 and 0.5.1 the package.xml went from version 1 to version 2. This seems to have broken the @data-dir@ and @package_version@ variable replacements that PEAR usually takes care of on installation of the software. The @package_version@ isn't really a problem, but the lack of replacement of @data-dir@ in HTML/AJAX/Server.php breaks HTML_AJAX applications. Since the version of the package.xml in CVS doesn't seem to be the same as the one that is used in release 0.5.1, the patch I created is located here: http://molior.mcs.suffolk.edu/patches/HTML_AJAX-data-dir.patch.bz2 Test script: --------------- <?php session_start(); require_once 'HTML/AJAX/Server.php'; class AutoServer extends HTML_AJAX_Server { } /* end class AutoServer */ $server = new AutoServer(); $server->handleRequest(); ?> Expected result: ---------------- Browsing to the test script above with ?client=all at the end of the URL in the browser should output the client JS code for HTML_AJAX. Actual result: -------------- alert('Unable to find javascript file: /HTML_AJAX.js');

Comments

 [2007-05-07 14:41 UTC] jeichorn (Joshua Eichorn)
Yeah we don't have cvs sync'd up with the subversion repo were working out of. Thanks for the patch, i'll do a quick 0.5.2 with the fix. I wonder why things worked on my test server.
 [2007-05-07 15:01 UTC] jeichorn (Joshua Eichorn)
Ok its fixed you should see 0.5.2 which installs correctly any moment now