Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.9.4

Bug #10944 Cannot install Package+Subpackage
Submitted: 2007-05-05 18:22 UTC Modified: 2007-05-28 10:13 UTC
From: cipri Assigned: cipri
Status: Closed Package: PEAR (version 1.5.3)
PHP Version: 5.2.1 OS: Fedora Core 6
Roadmaps: 1.6.0    
Subscription  


 [2007-05-05 18:22 UTC] cipri (Cipriano Groenendal)
Description: ------------ After splitting Mail_Mime into Mail_Mime and Mail_MimeDecode I get two packages. With the correct dependancies in place I am unable to install them; On my Fedora Core 6(php 5.2.1) server PHP will loop at 100% CPU untill it runs out of memory. On Berdir's s Suse (php 5.2.2+Xdebug) it installs just fine Test script: --------------- Download both http://www.cipri.com/pear/Mail_Mime-1.5.0RC1.tgz and http://www.cipri.com/pear/Mail_mimeDecode-0.1.0.tgz then run "pear upgrade *.tgz". List of installed packages: http://www.cipri.com/pear/pear-list-cipri.txt (Doesn't work) http://www.cipri.com/pear/pear-list-berdir.txt (Works)

Comments

 [2007-05-05 19:14 UTC] berdir (Sascha Grossenbacher)
Ok, i found out some more infos.. it gets in a endless loop inside PEAR_Downloader::download(). I don't know exactly why, but on line 363, it seems to loop the second entry of the array again and again.. changing those lines to: echo count($params) . "\n"; foreach ($params as $i => $param) { echo $i . ": "; echo $param->getShortName(); echo "\n"; gives me: 2 0: pear/Mail_Mime 1: pear/Mail_mimeDecode 1: pear/Mail_mimeDecode 1: pear/Mail_mimeDecode 1: pear/Mail_mimeDecode 1: pear/Mail_mimeDecode 1: pear/Mail_mimeDecode 1: pear/Mail_mimeDecode 1: pear/Mail_mimeDecode .... After that, I added this line after the one with getShortName(): echo key($params) then, the output was that: 2 0: pear/Mail_Mime 0 1: pear/Mail_mimeDecode upgrade ok: channel://pear.php.net/Mail_Mime-1.5.0RC1 upgrade ok: channel://pear.php.net/Mail_mimeDecode-0.1.0 On the second run, there is no actual key, but then it installs fine. It seems to me that something sets $params to a bad state, without an active key and a call to key() seems to repair that. This is really, really bad...
 [2007-05-06 04:54 UTC] cipri (Cipriano Groenendal)
Confirmed. Same files work for me on PHP-5.1.6, but not on 5.2.1. Seems to be a PHP bug?
 [2007-05-19 18:54 UTC] cellog (Greg Beaver)
this is definitely a PHP bug. We experienced a similar problem with phpDocumentor. Could you guys try to reproduce it to a smaller script? I'll do the same.
 [2007-05-20 04:30 UTC] berdir (Sascha Grossenbacher)
seems to be this bug, there is a simple example too http://bugs.php.net/bug.php?id=40768
 [2007-05-20 06:14 UTC] dufuz (Helgi ├×ormar)
Perhaps the way to go is to exclude 5.2.1 from 1.6 ? :) AFAIK we only experience this with the sub package behavior but still, better to get rid of all the bogus reports I think.
 [2007-05-20 06:58 UTC] cipri (Cipriano Groenendal)
We can't just not support that PHP version, as it may be used in the wild. I've uploaded a patch that fixes Downloader.php
 [2007-05-28 10:13 UTC] cellog (Greg Beaver)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.