Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.5.0a1

Bug #10910 DOM templates create incorrect trees
Submitted: 2007-05-02 10:28 UTC Modified: 2007-05-04 16:20 UTC
From: cardoe Assigned: ashnazg
Status: Closed Package: PhpDocumentor (version 1.3.2)
PHP Version: 5.2.1 OS: Gentoo
Roadmaps: 1.4.0a2    
Subscription  


 [2007-05-02 10:28 UTC] cardoe (Doug Goldstein)
Description: ------------ I'm using @package and @subpackage... Any interfaces or classes top level items appear above the proper @subpackage they belong in. I've attached a link to a screenshot highlighting the problem and did some ghetto GIMPing to show the correction. http://sourceforge.net/tracker/download.php?group_id=11194&atid=111194&file_id=225579&aid=1703258 This is a copy and paste of SourceForge bug #1703258 since it appears PEAR's bug tracker is preferred. Test script: --------------- Just use -o HTML:frames:DOM/phphtmllib to reproduce.

Comments

 [2007-05-03 12:11 UTC] ashnazg (Chuck Burgess)
I am able to duplicate this only against the HTML:frames:DOM/phpdoc.de and HTML:frames:DOM/phphtmllib converters... the other DOM converters line the menu items up perfectly. Also, I saw this behavior in 1.3.1, 1.3.2, 1.4.0a1, and the current CVS HEAD... I didn't check any older versions.
 [2007-05-04 14:48 UTC] ashnazg (Chuck Burgess)
Got this one figured out. It was just a matter of some "tree" variables that should have been "subpackagetree" instead. Josh, ready for review.
 [2007-05-04 16:20 UTC] ashnazg (Chuck Burgess)
Committed to CVS.