Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.9.4

Bug #10865 using --packagingroot regression
Submitted: 2007-04-28 03:15 UTC Modified: 2007-05-07 21:05 UTC
From: remicollet Assigned: tias
Status: Closed Package: PEAR (version 1.5.3)
PHP Version: 5.2.1 OS: Linux (Fedora)
Roadmaps: 1.5.4    
Subscription  


 [2007-04-28 03:15 UTC] remicollet (Remi Collet)
Description: ------------ When packaging PEAR extension to RPM, we use (for Fedora Extras) : pear install --nodeps --packagingroot $RPM_BUILD_ROOT package2.xml All works fine until PEAR-1.5.1 With PEAR-1.5.3, we get (for example) Ignoring installed package pear/PHP_Archive Nothing to install Seems pear badly check for the version installed. Using --force is a workaround, but this requires to update ALL already existing spec file :(

Comments

 [2007-04-28 09:14 UTC] tias (Tias Guns)
Hello Remi, Thank you for reporting this bug and sorry for the inconvenience it is giving you. At a certain stage the packagingroot was indeed forgotten when checking the installed version. The attached patch fixes this. Because this bug probably interferes with the RPM packaging, I've created a PEAR-1.5.3a that is 1.5.3 + this fix. You can find it at http://tias.ulyssis.org/patch/pear/PEAR-1.5.3a.tgz Do not hesitate to contact us if some other unexpected behaviour would be encountered. As a side note: In the documentation the option 'packagingroot' exists only for the commands 'install' and 'upgrade', not for 'upgrade-all' or 'uninstall'. Is this correct and wanted behaviour ? g,T
 [2007-04-28 11:06 UTC] remicollet (Remi Collet)
Thanks for the patch. The issue is solved. > As a side note: In the documentation the option 'packagingroot' exists only for the commands 'install' and 'upgrade', not for 'upgrade-all' or 'uninstall'. Is this correct and wanted behaviour ? Yes. This command is used to build a RPM which always (AFAIK) provide only 1 extension. In Fact only "install" seems usefull (an RPM_BUILD_ROOT is always empty). With RPM, the post (un)install scriptlet use "pear (un)install --register-only". Regards
 [2007-04-28 12:58 UTC] cellog (Greg Beaver)
tias: yes packagingroot is only needed for install in order to create a package. The uninstall command is done on the client machine
 [2007-04-28 14:31 UTC] tias (Tias Guns)
greg: thanks for the info. The new version of the attached patch only makes changes for the 'install' command. Plus it corrects documentation accordingly.
 [2007-05-06 18:18 UTC] cellog (Greg Beaver)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.