Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.9.5

Bug #10847 Cannot retrieve channel.xml for channel "pear.php.net"
Submitted: 2007-04-26 14:09 UTC Modified: 2007-04-29 13:28 UTC
From: toggg Assigned:
Status: Duplicate Package: PEAR (version 1.5.3)
PHP Version: 5.1.6 OS:
Roadmaps: (Not assigned)    
Subscription  


 [2007-04-26 14:09 UTC] toggg (bertrand Gugger)
Description: ------------ Several command gives a warning like: # pear remote-info Text_Wiki WARNING: channel "pear.php.net" has updated its protocols, use "channel-update pear.php.net" to update But # pear channel-update pear.php.net Updating channel "pear.php.net" Cannot retrieve channel.xml for channel "pear.php.net" Not sure if it's a pear or pearweb bug... Versions: # pear -V PEAR Version: 1.5.3 PHP Version: 5.1.6 Zend Engine Version: 2.1.0 Running on: Linux ancilla.toggg.net 2.6.20-1.2312.fc5smp #1 SMP Tue Apr 10 15:30:02 EDT 2007 i686

Comments

 [2007-04-28 09:27 UTC] tias (Tias Guns)
Its a pear thing: temp_dir existence, see Bug #10873
 [2007-04-28 20:30 UTC] toggg (bertrand Gugger)
I wonder how you can set a bug as duplicate of a bug which did not exist as it was created ... Anyway, that solved it: # pear channel-update pear.php.net Updating channel "pear.php.net" Cannot retrieve channel.xml for channel "pear.php.net" # pear config-get temp_dir /tmp/pear/temp # ls /tmp/pear/temp ls: /tmp/pear/temp: No such file or directory # ls /tmp/pear cache # mkdir /tmp/pear/temp # pear channel-update pear.php.net Updating channel "pear.php.net" Update of Channel "pear.php.net" succeeded
 [2007-04-29 13:28 UTC] tias (Tias Guns)
don't take it personal that I marked it duplicate, the other just gave the anwser ; ) Apparently using channel-update -f pear.php.net also works. But lets focus on getting a real solution in the other report : )