Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.26.0

Bug #10731 "Doc Bug" doesn't appear on Roadmap
Submitted: 2007-04-14 23:45 UTC Modified: 2007-06-16 13:03 UTC
From: ashnazg Assigned: dufuz
Status: Duplicate Package: pearweb
PHP Version: Irrelevant OS: pear.php.net (??)
Roadmaps: 1.15.0    
Subscription  


 [2007-04-14 23:45 UTC] ashnazg (Chuck Burgess)
Description: ------------ A bug I classified as a "Doc Bug" and then assigned to a given roadmap does not appear on that roadmap's list of items, neither the "bug" list nor the "feature" list. Does the Roadmap feature need an extra section for the "Doc Bug" classification, or should they be shown in the "bug" list? Test script: --------------- Look at PhpDocumentor bug #10730. It is a "Doc Bug" that I assigned to roadmap 1.4.0a1. When viewing the bug, you will see it assigned to that roadmap. When viewing the roadmap, there is no trace of this bug. Expected result: ---------------- See bug #10730 appear on the 1.4.0a1 roadmap. Actual result: -------------- Don't see bug #10730 on any roadmap.

Comments

 [2007-04-27 22:56 UTC] davidc (David Coallier)
This is pretty much done, but I do not dare marking it as closed until someone else tested it.
 [2007-04-27 22:57 UTC] davidc (David Coallier)
Sorry wrong bug. I will address this bug tonight.
 [2007-04-27 23:42 UTC] davidc (David Coallier)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.
 [2007-05-30 20:06 UTC] ashnazg (Chuck Burgess)
I'm still seeing this bug at pear.php.net's bug tracker, specifically I'm not seeing any of my Doc bugs on PhpDocumentor for the 1.4.0a2 roadmap. Has pearweb at pear.php.net just not yet up to v1.15.0 yet?
 [2007-06-15 09:17 UTC] ashnazg (Chuck Burgess)
davidc, any chance you closed the wrong bug on 4/28? This bug is still evident at pear.php.net. Look at PhpDocumentor's roadmap for 1.4.0a2. When you first see it listed on the Roadmaps page, it shows "100% done: 8 fixed of 8", but when you expand it to list the bugs, it only shows 4, the four Bugs, and excludes the four Doc items.
 [2007-06-15 10:11 UTC] davidc (David Coallier)
I'll give a look at that tonight. Thanks,
 [2007-06-16 13:03 UTC] dufuz (Helgi ├×ormar)
Duplicate of Bug #11259 ... Well I suppose that one is duplicate of this one but well easier this way.