Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.26.0

Bug #10709 Can not reset my password
Submitted: 2007-04-13 04:43 UTC Modified: 2007-04-28 14:25 UTC
From: till Assigned: cellog
Status: Closed Package: pearweb (version 1.12.1)
PHP Version: Irrelevant OS: any
Roadmaps: 1.15.0    
Subscription  


 [2007-04-13 04:43 UTC] till (Till Klampaeckel)
Description: ------------ I tried to reset my password using the webform. Unfortunately I never got an email to complete "resetting". Also, the website also doesn't state if it actually did something - which is of course probably not a bug, but maybe a usability thing.

Comments

 [2007-04-17 17:06 UTC] cellog (Greg Beaver)
please try again, it works for me here
 [2007-04-24 14:42 UTC] egobug (Ego Bug)
Same problem for myself. :(
 [2007-04-27 22:58 UTC] davidc (David Coallier)
Have you tried clearing your cache ? Please let us know if it works (Works for me here as well)
 [2007-04-28 05:52 UTC] till (Till Klampaeckel)
Yes, problem still exists. I just tried to request a password for my account "till" and I received no email so far. I just emailed pear-qa to get it reset, but the form doesn't work. Btw, is it supposed to say anything? Kinda like "details sent" when you submit the form with the new passwords?
 [2007-04-28 08:09 UTC] till (Till Klampaeckel)
This is weird, I logged in with my second PEAR account (lagged), went to the form and requested a change for my account (till) and it worked! "WARNING: your password will NOT be changed until you confirm the request through instructions in your email." And I also received the email! ;-) And I also reset the password, it all worked. So I guess the bug is that you need to be logged in to request the password change?
 [2007-04-28 12:53 UTC] cellog (Greg Beaver)
yes, it is supposed to say something. If it doesn't show anything, then the form is not being submitted. what is your browser?
 [2007-04-28 12:55 UTC] cellog (Greg Beaver)
which one of your PEAR accounts would you like to delete? Only 1 account is allowed per developer I can confirm the bug now - I'll have a fix shortly.
 [2007-04-28 13:23 UTC] till (Till Klampaeckel)
I'd like to keep "till", so please get rid off "lagged". By the way, can you check permissions on "till" for the bugtracker? It doesn't seem to be allowed to post here.
 [2007-04-28 13:27 UTC] cellog (Greg Beaver)
done. I magically changed all references to lagged into till in the bug tracker and removed the lagged account
 [2007-04-28 13:30 UTC] till (Till Klampaeckel)
Thank you very much!
 [2007-04-28 13:32 UTC] cellog (Greg Beaver)
please try now, I was able to get it to work.
 [2007-04-28 14:25 UTC] cellog (Greg Beaver)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.