Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.0.5

Bug #10702 Indirect modification of overloaded property
Submitted: 2007-04-12 13:59 UTC Modified: 2008-03-30 15:57 UTC
From: tkatkov Assigned: jystewart
Status: Closed Package: XML_Feed_Parser (version 1.0.2)
PHP Version: 5.2.1 OS: Windows XP SP2
Roadmaps: (Not assigned)    
Subscription  


 [2007-04-12 13:59 UTC] tkatkov (Taras Katkov)
Description: ------------ I am getting constant flow of those errors in error.log of web server: Indirect modification of overloaded property XML_Feed_Parser_Atom::$idMappings has no effect in C:\\Program Files\\PHP\\PEAR\\XML\\Feed\\Parser\\Type.php on line 198, referer: http://xx/pic2/ Test script: --------------- <?php require_once('XML/Feed/Parser.php'); require_once('HTTP/Request.php'); $url = 'http://picasaweb.google.com/data/feed/api/user/m.tacker.org?kind=album&access=public'; $request = new HTTP_Request($url); $request->sendRequest(); $feed = new XML_Feed_Parser($request->getResponseBody(), false, true, true); $albums = array(); foreach ($feed as $entry) { $albums[] = array( $entry->title, $entry->link ); } echo '<body>done</body>'; ?>

Comments

 [2007-04-12 15:52 UTC] jystewart (James Stewart)
This appears to be a bug in PHP 5.2.1. There's a fix in PHP CVS. http://bugs.php.net/bug.php?id=39449
 [2007-07-27 02:01 UTC] blueskysora (Sora, Choi)
. . /** 47 * Where we store our entry objects once instantiated 48 * @var array 49 */ 50 public $entries = array(); 51 public $idMappings = array(); // Add code here. . .
 [2008-01-22 11:39 UTC] lsmith (Lukas Smith)
Just FYI. I ran into the same issue on PHP 5.2.5, so I reopened the bug report on bugs.php.net.
 [2008-03-27 09:55 UTC] cweiske (Christian Weiske)
it brings a notice, so the issue is not PHP but the parser
 [2008-03-27 09:59 UTC] cweiske (Christian Weiske)
the code addition from blueskysora (Sora, Choi) makes it work.
 [2008-03-30 15:57 UTC] jystewart (James Stewart)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.