Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.9.4

Request #10667 Allow dependencies on API
Submitted: 2007-04-09 14:10 UTC Modified: 2009-03-26 21:57 UTC
From: timj Assigned: dufuz
Status: Assigned Package: PEAR (version CVS)
PHP Version: Irrelevant OS:
Roadmaps: 2.0.0    
Subscription  


 [2007-04-09 14:10 UTC] timj (Tim Jackson)
Description: ------------ This is a PEAR2 thing, probably. It seems rather a shame that although we have an <api> version tag in package.xml, you can't use it as a dependency. In some ways, *IF* this is being used properly, it would make more sense than a package version dependency. Certainly this is true in some circumstances. Therefore, PEAR2 should perhaps support a dep something like this: <required> <package> <name>Foo_Bar</name> <min type="api">1.0.0</min> <max type="api">1.0.2</max> <recommended type="api">1.0.1</recommended> </package> </required> (the implicit default "type" attribute for <min>,<max> etc. would be "packagever" or something)

Comments

 [2009-02-09 22:02 UTC] dufuz (Helgi Þormar Þorbjörnsson)
-Roadmap Versions: 2.0.0, 1.8.0alpha1 +Roadmap Versions: 2.0.0, 1.8.0alpha1, 1.8.0alpha2
Move to alpha2
 [2009-03-26 21:57 UTC] dufuz (Helgi Þormar Þorbjörnsson)
-Roadmap Versions: 2.0.0, 1.8.0alpha1, 1.8.0RC1 +Roadmap Versions: 2.0.0, 1.8.0alpha1
Postponed again so we can make it into PHP 5.3 on time.
 [2009-03-26 21:57 UTC] dufuz (Helgi Þormar Þorbjörnsson)
-Roadmap Versions: 2.0.0, 1.8.0alpha1 +Roadmap Versions: 2.0.0