Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.7.5

Bug #10430 remote-info broken for installed packages
Submitted: 2007-03-20 14:55 UTC Modified: 2007-03-27 14:31 UTC
From: tias Assigned: tias
Status: Closed Package: PEAR_Frontend_Web (version 0.5.1)
PHP Version: Irrelevant OS:
Roadmaps: 0.5.2    
Subscription  


 [2007-03-20 14:55 UTC] tias (Tias Guns)
Description: ------------ The problem is that the webfrontend want's to show the 'downloadURL' incase somebody would want to download the package manually. This downloadURL is useless, as nobody installes packages by downloading the tgz and then doing stuff with it. Other then its uselessness, it uses the private function _getPackageDownloadURL() which has apparently changed its API since the webfrontend was written. In stead of trying to fix this, I decided to comment this all out. This simple solution makes the remote-info work again (the page that is called when asking for more info on a package). The patch can be found attached or at http://tias.ulyssis.org/pear/frontend_web/0.5.1/ g,T

Comments

 [2007-03-27 14:31 UTC] tias (Tias Guns)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.