Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.7.0

Bug #10409 Subversion 1.4.x entries files not supported
Submitted: 2007-03-18 14:13 UTC Modified: 2007-04-03 22:21 UTC
From: timj Assigned: timj
Status: Closed Package: PEAR_PackageFileManager (version 1.6.0)
PHP Version: 5.1.6 OS:
Roadmaps: 1.6.1    
Subscription  


 [2007-03-18 14:13 UTC] timj (Tim Jackson)
Description: ------------ Subversion 1.4 uses a completely different file format for its "entries" files (which contain a list of files in the working copy). The file format is no longer XML, for a start. See http://subversion.tigris.org/svn_1.4_releasenotes.html for an overview. PEAR_PackageFileManager only supports SVN < 1.4 working copies. Attempts to use a SVN 1.4 working copy with PFM via the "filelistgenerator" option set to "svn" result in streams of errors like: PHP Warning: simplexml_load_string(): ^ in /path/to/PEAR/PackageFileManager/Svn.php on line 161 At the least, PFM could recognise that the entries file is not in a supported format and give a graceful error.

Comments

 [2007-03-18 14:21 UTC] timj (Tim Jackson)
I can't immediately find a reference to the new non-XML format. However there is a .svn/format file which I believe contains a version number of the working copy format. So for compatibility checking we may be able to use this. From observation, a SVN 1.2 working copy has the string "4" in .svn/format and a SVN 1.4 working copy has the string "8". This link may be useful: http://svn.haxx.se/dev/archive-2006-04/0337.shtml
 [2007-03-18 16:21 UTC] timj (Tim Jackson)
I have attached a patch which makes this work with Subversion 1.4 entries files for me. It is rather hacky and entirely based on observation of the "entries" file format since I have not been able to find any authoritative documentation (although I'm sure it exists). The right fix is to ask the SVN folks for documentation but this may solve the problem in the meantime. It also fixes a possible E_NOTICE ($entries not defined)
 [2007-03-25 06:03 UTC] timj (Tim Jackson)
Updated patch (pear-fix-svn-1.4-version2.patch) attached which is an improvement on the earlier one to improve handling of svn delete'd files. It also contains the fix to bug #10410.
 [2007-04-01 22:49 UTC] cellog (Greg Beaver)
not a feature request, this is unexpected behavior
 [2007-04-03 22:21 UTC] cellog (Greg Beaver)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.