Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.9.4

Bug #10402 Missing versions with remote-list
Submitted: 2007-03-16 08:24 UTC Modified: 2007-03-26 10:19 UTC
From: yunosh Assigned: cellog
Status: Closed Package: PEAR (version 1.5.1)
PHP Version: Irrelevant OS:
Roadmaps: 1.5.2    
Subscription  


 [2007-03-16 08:24 UTC] yunosh (Jan Schneider)
Description: ------------ Using 'pear remote-list' shows a lot of n/a where there should be package versions, e.g. Cache that has both a stable and a more recent beta version.

Comments

 [2007-03-26 00:29 UTC] cellog (Greg Beaver)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.
 [2007-03-26 03:08 UTC] yunosh (Jan Schneider)
I don't see any difference, even after clearing the cache before calling remote-list.
 [2007-03-26 09:37 UTC] cellog (Greg Beaver)
cellog@lot-49:~/workspace/pear-core$ sudo pear up -f PEAR Password: Did not download optional dependencies: pear/XML_RPC, use --alldeps to download automatically pear/PEAR can optionally use package "pear/XML_RPC" (version >= 1.4.0) downloading PEAR-1.5.1.tgz ... Starting to download PEAR-1.5.1.tgz (290,252 bytes) ............................................................done: 290,252 bytes upgrade ok: channel://pear.php.net/PEAR-1.5.1 PEAR: Optional feature webinstaller available (PEAR's web-based installer) PEAR: Optional feature gtkinstaller available (PEAR's PHP-GTK-based installer) PEAR: Optional feature gtk2installer available (PEAR's PHP-GTK2-based installer) To install use "pear install pear/PEAR#featurename" cellog@lot-49:~/workspace/pear-core$ pear remote-list |grep Cache Cache -n/a- Cache_Lite 1.7.2 cellog@lot-49:~/workspace/pear-core$ sudo pear up package2.xml Did not download optional dependencies: pear/XML_RPC, use --alldeps to download automatically pear/PEAR can optionally use package "pear/XML_RPC" (version >= 1.4.0) upgrade ok: channel://pear.php.net/PEAR-1.5.2 PEAR: Optional feature webinstaller available (PEAR's web-based installer) PEAR: Optional feature gtkinstaller available (PEAR's PHP-GTK-based installer) PEAR: Optional feature gtk2installer available (PEAR's PHP-GTK2-based installer) To install use "pear install pear/PEAR#featurename" cellog@lot-49:~/workspace/pear-core$ pear remote-list |grep Cache Cache 1.5.4 Cache_Lite 1.7.2
 [2007-03-26 09:50 UTC] yunosh (Jan Schneider)
jan@neo:~/headhorde> pear remote-list | grep n/a | head -10 LiveUser -n/a- Auth_PrefManager2 -n/a- LiveUser_Admin -n/a- DBA_Relational -n/a- SQL_Parser -n/a- DB_ldap2 -n/a- Gtk_MDB_Designer -n/a- DB_DataObject_FormBuilder -n/a- DB_Sqlite_Tools -n/a- MDB2_Schema -n/a- I should mention that I upgraded to the latest CVS code now.
 [2007-03-26 09:55 UTC] cellog (Greg Beaver)
Hi Jan, The packages you list all have no stable releases, and so n/a actually is the correct answer if you have preferred_state="stable" If, however, you get the same list with preferred_state="beta" we have a problem
 [2007-03-26 10:19 UTC] yunosh (Jan Schneider)
You are right. I have to admit that this was my very first idea too, even before reporting this issue. But since this list had so many 0.x releases, I was sure it was unrelated to the package state. Unfortunately we simply have that many packages that have been released - long before the numbering standards - with 0.x releases being marked as stable. My fault.