Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.9.4

Request #10182 add resolution of PHP dependency prior to download
Submitted: 2007-02-25 13:10 UTC Modified: 2007-05-28 11:29 UTC
From: cellog Assigned: cellog
Status: Closed Package: PEAR (version CVS)
PHP Version: Irrelevant OS: n/a
Roadmaps: 1.6.0, 2.0.0    
Subscription  


 [2007-02-25 13:10 UTC] cellog (Greg Beaver)
Description: ------------ Currently, the only resolution of dependencies used to determine which package to download is in stability. The PHP version supported by the package should also be used. This would allow maintaining parallel versions of the same package *without* having to create a new package just for upping the PHP version. In other words, Package version 1.2.x could be for PHP 4, whereas Package version 1.3.x could be for PHP 5+ This would resolve a whole slew of political issues in PEAR

Comments

 [2007-05-19 19:27 UTC] cellog (Greg Beaver)
I'll do this for 1.6
 [2007-05-28 11:29 UTC] cellog (Greg Beaver)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.