Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.1.4

Request #10119 CTCP version reply should be fully configurable
Submitted: 2007-02-18 21:56 UTC Modified: 2007-08-10 04:34 UTC
From: ian at mywits-end dot co dot uk Assigned: amir
Status: Closed Package: Net_SmartIRC (version 1.0.0)
PHP Version: Irrelevant OS: Linux
Roadmaps: (Not assigned)    
Subscription  


 [2007-02-18 21:56 UTC] ian at mywits-end dot co dot uk (Ian Gibbons)
Description: ------------ Currently, the CTCP VERSION reply is only partly configurable, since it always has ' | using $smartirc_version' suffixed to what you set with setCtcpVersion(). One would expect that what you set with this command is what you'll see on irc, and so this patch changes Net/SmartIRC/messagehandler.php to do just that. Apply with "patch -p0 < messagehandler.php.patch". The patch assumes php/pear is in /usr/share/php, so you may need to adjust accordingly by editing the patch if this is not correct for your system. Kind Regards, Ian Test script: --------------- Download patch from: http://www.mywits-end.co.uk/messagehandler.php.patch

Comments

 [2007-08-10 04:34 UTC] amir (Amir Mohammad Saied)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.